Merge commit 'upstream/2.6.1'
authorBdale Garbee <bdale@gag.com>
Sun, 15 Feb 2009 19:41:31 +0000 (12:41 -0700)
committerBdale Garbee <bdale@gag.com>
Sun, 15 Feb 2009 19:41:31 +0000 (12:41 -0700)
1  2 
gnulib/regenerate/regenerate

index a32ab348b93e2dede03fa7401213099f9a5cef06,5669916877d155590ea73614af595138a9ddc032..5669916877d155590ea73614af595138a9ddc032
mode 100644,100755..100644
@@@ -1,7 -1,10 +1,10 @@@
  #! /bin/bash
  
- # Gnulib files in zmanda repo are from gnulib CVS updated with:
- #   cvs update -D '2007-10-25 17:00:00 -0600'
+ # Gnulib files in zmanda repo are from gnulib GIT.  To check out the
+ # same version as was used to generate the source in the repository,
+ # run the following in your git repository:
+ #
+ #   git checkout 03400ebfaa064922caf3767d6641d7e1cdc8cd1b
  
  # get to the project root
  cd `dirname $0`/../..
@@@ -36,7 -39,8 +39,8 @@@ shopt -u nullglo
  ## Add your modules here, then see below if you need to patch them. ##
  ######################################################################
  
- GNULIB_MODULES="getaddrinfo lock visibility base64 physmem fsusage mkdtemp"
+ GNULIB_MODULES="getaddrinfo lock visibility base64 physmem fsusage"
+ GNULIB_MODULES="$GNULIB_MODULES mkdtemp getopt full-read full-write"
  
  ######################################################################
  ## End modules                                                      ##
@@@ -59,16 -63,17 +63,17 @@@ PATCH_DIR="`pwd`/gnulib/regenerate
  # Patch Makefile.am to not error out on warnings
  patch -p0 < "${PATCH_DIR}/no-error.patch" || exit 1
  
  # Add John's patches to getaddrinfo.c for use in cygwin
  patch -p0 < "${PATCH_DIR}/getaddrinfo-cygwin.patch" || exit 1
  
+ # Add John's patches to eliminate restrict attributes.
+ patch -p0 < "${PATCH_DIR}/no-restrict.patch" || exit 1
  
  # Add info to the makefile to ensure all this stuff gets put in
  # the distribution tarball
  (   echo ""
      echo "# Make sure regenerate/* are in the distribution tarball"
-     echo "EXTRA_DIST += "`cd gnulib; find regenerate -name .svn -prune -o -type f -print `
+     echo "EXTRA_DIST += "`cd gnulib; find regenerate -name .svn -prune -o -type f -print | sort`
  ) >> gnulib/Makefile.am
  
  ######################################################################