patch to fix kfreebsd FTBFS
authorBdale Garbee <bdale@gag.com>
Fri, 13 Apr 2012 05:29:31 +0000 (23:29 -0600)
committerBdale Garbee <bdale@gag.com>
Fri, 13 Apr 2012 05:29:31 +0000 (23:29 -0600)
common-src/glib-util.c
debian/changelog
debian/patches/kfreebsd-ftbfs.diff [new file with mode: 0644]
debian/patches/series

index 6a42e8e2b4324900cb7f433080f3c2bf733975e8..99f55f7aa8a91824fbb2d9202dc4fcc2fa1b9f3e 100644 (file)
@@ -38,12 +38,8 @@ glib_init(void) {
     if (did_glib_init) return;
     did_glib_init = TRUE;
 
-    /* set up libcurl (this must happen before threading 
-     * is initialized) */
+    /* set up libcurl */
 #ifdef HAVE_LIBCURL
-# ifdef G_THREADS_ENABLED
-    g_assert(!g_thread_supported()); /* assert threads aren't initialized yet */
-# endif
     g_assert(curl_global_init(CURL_GLOBAL_ALL) == 0);
 #endif
 
@@ -64,12 +60,6 @@ glib_init(void) {
     /* Initialize glib's type system.  On glib >= 2.24, this will initialize
      * threads, so it must be done after curl is initialized. */
     g_type_init();
-
-    /* And set up glib's threads */
-#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
-    if (!g_thread_supported())
-       g_thread_init(NULL);
-#endif
 }
 
 typedef enum {
index 377f65ba02ea4d5d8c23351bd330731384d9851b..3c58fb652cab28408a9cc9f06fd6b80a53a3f80a 100644 (file)
@@ -1,3 +1,9 @@
+amanda (1:3.3.1-3) unstable; urgency=low
+
+  * patch from Robert Milan to fix kfreebsd FTBFS, closes: #667836
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 12 Apr 2012 23:29:14 -0600
+
 amanda (1:3.3.1-2) unstable; urgency=low
 
   * patch from Michael Biebl to elide g_queue_free_full definition that
diff --git a/debian/patches/kfreebsd-ftbfs.diff b/debian/patches/kfreebsd-ftbfs.diff
new file mode 100644 (file)
index 0000000..d8b02aa
--- /dev/null
@@ -0,0 +1,31 @@
+diff --git a/common-src/glib-util.c b/common-src/glib-util.c
+index 6a42e8e..99f55f7 100644
+--- a/common-src/glib-util.c
++++ b/common-src/glib-util.c
+@@ -38,12 +38,8 @@ glib_init(void) {
+     if (did_glib_init) return;
+     did_glib_init = TRUE;
+-    /* set up libcurl (this must happen before threading 
+-     * is initialized) */
++    /* set up libcurl */
+ #ifdef HAVE_LIBCURL
+-# ifdef G_THREADS_ENABLED
+-    g_assert(!g_thread_supported()); /* assert threads aren't initialized yet */
+-# endif
+     g_assert(curl_global_init(CURL_GLOBAL_ALL) == 0);
+ #endif
+@@ -64,12 +60,6 @@ glib_init(void) {
+     /* Initialize glib's type system.  On glib >= 2.24, this will initialize
+      * threads, so it must be done after curl is initialized. */
+     g_type_init();
+-
+-    /* And set up glib's threads */
+-#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
+-    if (!g_thread_supported())
+-      g_thread_init(NULL);
+-#endif
+ }
+ typedef enum {
index 50e77b06d1dcc2f37e8c6b49b1cf83c911074ba1..de4e07db022f340c8d55b7a7998a0ba178f61748 100644 (file)
@@ -1,2 +1,3 @@
 dumpdates-path
 glib-2.32.patch
+kfreebsd-ftbfs.diff