Imported Debian patch 2.5.1p1-2.1 debian/2.5.1p1-2.1
authorPeter Palfrader <weasel@debian.org>
Wed, 29 Nov 2006 00:57:01 +0000 (01:57 +0100)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 04:47:39 +0000 (22:47 -0600)
config/config.sub
debian/changelog
debian/po/templates.pot
debian/postrm

index fab0aa3556632a4aec253b77804270a096c11c3e..387c18d1a135c2e33cb9f911c198efdf7b12b96c 100755 (executable)
@@ -4,7 +4,7 @@
 #   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 #   Inc.
 
-timestamp='2006-09-20'
+timestamp='2006-07-02'
 
 # This file is (in principle) common to ALL GNU software.
 # The presence of a machine in this file suggests that SOME GNU software
@@ -276,7 +276,6 @@ case $basic_machine in
        | pdp10 | pdp11 | pj | pjl \
        | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
        | pyramid \
-       | score \
        | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
        | sh64 | sh64le \
        | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
@@ -285,7 +284,7 @@ case $basic_machine in
        | tahoe | thumb | tic4x | tic80 | tron \
        | v850 | v850e \
        | we32k \
-       | x86 | xc16x | xscale | xscalee[bl] | xstormy16 | xtensa \
+       | x86 | xscale | xscalee[bl] | xstormy16 | xtensa \
        | z8k)
                basic_machine=$basic_machine-unknown
                ;;
@@ -368,7 +367,7 @@ case $basic_machine in
        | tron-* \
        | v850-* | v850e-* | vax-* \
        | we32k-* \
-       | x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
+       | x86-* | x86_64-* | xps100-* | xscale-* | xscalee[bl]-* \
        | xstormy16-* | xtensa-* \
        | ymp-* \
        | z8k-*)
@@ -910,10 +909,6 @@ case $basic_machine in
        sb1el)
                basic_machine=mipsisa64sb1el-unknown
                ;;
-       sde)
-               basic_machine=mipsisa32-sde
-               os=-elf
-               ;;
        sei)
                basic_machine=mips-sei
                os=-seiux
@@ -1371,9 +1366,6 @@ else
 # system, and we'll never get to this point.
 
 case $basic_machine in
-        score-*)
-               os=-elf
-               ;;
         spu-*)
                os=-elf
                ;;
index 0bed6fef93df675b65e5c5865c7a71aedd9a4f56..257ea65e5e869139dcd098eb2ef6d1ff7019a382 100644 (file)
@@ -1,3 +1,15 @@
+amanda (1:2.5.1p1-2.1) unstable; urgency=medium
+
+  * Non maintainer upload.
+  * Do not fail postrm when removing the backup user from either
+    group disk or tape does not succeed.  Also, try this only
+    when the backup user is in those groups to begin with.  Also
+    handles the case of deluser not existing anymore.
+    Based in parts on the patch provided by Andreas Henriksson and
+    the cupsys postinst script (closes: #399790).
+
+ -- Peter Palfrader <weasel@debian.org>  Wed, 29 Nov 2006 01:57:01 +0100
+
 amanda (1:2.5.1p1-2) unstable; urgency=medium
 
   * fix broken way of setting default CLN_AMANDATES in client-src/clientconf.c
index d2f6df88cbf61ecca07ece1a4ba550b0af90c20b..229d55f4cfe7aa3ddeddaeef87db38cd0d6774af 100644 (file)
@@ -8,7 +8,7 @@ msgid ""
 msgstr ""
 "Project-Id-Version: PACKAGE VERSION\n"
 "Report-Msgid-Bugs-To: bdale@gag.com\n"
-"POT-Creation-Date: 2006-10-29 11:41-0700\n"
+"POT-Creation-Date: 2006-11-29 02:13+0100\n"
 "PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
 "Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
 "Language-Team: LANGUAGE <LL@li.org>\n"
index 6c4bba9a9f0ad231f6589d2c336feb2d9b008e43..551a3cc7918cc7647a59e14e806d7d3e0a7bca67 100644 (file)
@@ -27,8 +27,17 @@ case "$1" in
 
        rm -f ~backup/.amandahosts
 
-       deluser backup disk
-       deluser backup tape
+       if which deluser >/dev/null 2>&1 ; then
+               for group in disk tape; do
+                       # only call deluser when backup is in $group
+                       if getent group "$group" |
+                          awk -F: '{ print $4 }' |
+                          awk -F, '{ for (i=1; i <= NF; i++ ) print $i }' |
+                          grep '^backup$' > /dev/null; then
+                               deluser backup "$group" || true
+                       fi
+               done
+       fi
   ;;
   remove|upgrade|deconfigure)
   ;;