patch to fix glib 2.32 build conflict
authorBdale Garbee <bdale@gag.com>
Tue, 3 Apr 2012 01:37:38 +0000 (18:37 -0700)
committerBdale Garbee <bdale@gag.com>
Tue, 3 Apr 2012 01:37:38 +0000 (18:37 -0700)
debian/changelog
debian/patches/glib-2.32.patch [new file with mode: 0644]
debian/patches/series

index 7405262ed7e6478530531224f1956c508802c4e1..2b277c999764ca5892af93d4e12f6c256b1e9731 100644 (file)
@@ -1,3 +1,10 @@
+amanda (1:3.3.1-2) unstable; urgency=low
+
+  * patch from Michael Biebl to elide g_queue_free_full definition that
+    conflicts with glib 2.32 but isn't actually used, closes: #665675
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 02 Apr 2012 18:36:36 -0700
+
 amanda (1:3.3.1-1) unstable; urgency=low
 
   * new upstream version, closes: #655025, #658933
diff --git a/debian/patches/glib-2.32.patch b/debian/patches/glib-2.32.patch
new file mode 100644 (file)
index 0000000..d4b1429
--- /dev/null
@@ -0,0 +1,38 @@
+Description: Remove g_queue_free_full() since it conflicts with glib 2.32
+ glib 2.32 introduce g_queue_free_full() which conflicts with the
+ amanda-internal version of this function. As it doesn't seem to
+ be used, simply remove it.
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665675
+
+Index: amanda-3.3.1/common-src/glib-util.c
+===================================================================
+--- amanda-3.3.1.orig/common-src/glib-util.c   2012-02-21 12:36:51.000000000 +0100
++++ amanda-3.3.1/common-src/glib-util.c        2012-03-31 01:33:21.177134297 +0200
+@@ -120,15 +120,6 @@
+ }
+ #endif
+-void g_queue_free_full(GQueue * queue) {
+-    while (!g_queue_is_empty(queue)) {
+-        gpointer data;
+-        data = g_queue_pop_head(queue);
+-        amfree(data);
+-    }
+-    g_queue_free(queue);
+-}
+-
+ void g_ptr_array_free_full(GPtrArray * array) {
+     size_t i;
+Index: amanda-3.3.1/common-src/glib-util.h
+===================================================================
+--- amanda-3.3.1.orig/common-src/glib-util.h   2012-02-21 12:36:51.000000000 +0100
++++ amanda-3.3.1/common-src/glib-util.h        2012-03-31 01:33:29.013134019 +0200
+@@ -72,7 +72,6 @@
+ /* These functions all take a GLib container, and call free() on all the
+  * pointers in the container before free()ing the container itself. */
+-void g_queue_free_full(GQueue * queue);
+ void g_ptr_array_free_full(GPtrArray * array);
+ /* g_value_compare() does what you expect. It returns TRUE if and
index 4bd2880124cf079b7c08ba093f6f55d7dac3c2ff..50e77b06d1dcc2f37e8c6b49b1cf83c911074ba1 100644 (file)
@@ -1 +1,2 @@
 dumpdates-path
+glib-2.32.patch