add make check to the rules file
[debian/amanda] / debian / rules
index 315df6cf9f880979c56c1ffe0661cb5df608b8ce..a26fcc19bcbfd7166ebe54e975130e5c9170e01a 100755 (executable)
@@ -15,15 +15,17 @@ configure-stamp:
        # pick up latest config files provided by autotools-dev
        cp -f /usr/share/misc/config.sub config/config.sub
        cp -f /usr/share/misc/config.guess config/config.guess
-       MAILER=/usr/bin/mail \
-
        # do we need --{htmldir,dvidir,pdfdir,psdir} to force subdirectories?
        # should we re-craft this to use --without-server and --without-client,
        #       and lose the amanda-common package?
+       MAILER=/usr/bin/mail \
+       SSH=/usr/bin/ssh \
        ./configure \
                --prefix=/usr \
                --bindir=/usr/sbin \
                --libexecdir=/usr/lib/amanda \
+               --without-amlibexecdir \
+               --without-amperldir \
                --sysconfdir=/etc \
                --sharedstatedir=/var/lib \
                --localstatedir=/var/lib \
@@ -32,23 +34,30 @@ configure-stamp:
                --with-tcpportrange=50000,50100 \
                --with-udpportrange=840,860 \
                --with-debugging=/var/log/amanda \
+               --with-gnutar-listdir=/var/lib/amanda/gnutar-lists \
                --with-index-server=localhost \
-
                --with-bsd-security \
-               --with-amandahosts \
                --with-smbclient=/usr/bin/smbclient \
+               --with-amandahosts \
                --with-ssh-security \
                --with-bsdtcp-security \
-               --with-bsdudp-security
+               --with-bsdudp-security \
+               --without-ipv6
+
        touch missing
        touch configure-stamp
 
 build: build-stamp 
 build-stamp: configure-stamp
        dh_testdir
-       MAILER=/usr/bin/mail make CFLAGS="-O2 -g -Wall \
+       MAILER=/usr/bin/mail $(MAKE) CFLAGS="-O2 -g -Wall \
                -DAMANDATES_FILE='\"/var/lib/amanda/amandates\"' \
                -DIGNORE_TAR_ERRORS "
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+       $(MAKE) check
+endif
+endif
        touch build-stamp
 
 clean:
@@ -87,6 +96,7 @@ binary-arch: build
        dh_strip -a
        dh_compress -a
        dh_movefiles -a --sourcedir=debian/amanda-common
+       rm -r $(r)/usr/share/amanda
        rm $(s)/usr/lib/amanda/chg-mtx
        dh_fixperms -av
        # fix perms manually
@@ -100,6 +110,9 @@ binary-arch: build
        chmod -R u=rwX,g=rwX,o-rwx $(c)/var/lib/amanda/gnutar-lists
        # .. setuid
        chown root:backup \
+               $(c)/usr/lib/amanda/application/amgtar \
+               $(c)/usr/lib/amanda/application/amstar \
+               $(c)/usr/lib/amanda/calcsize \
                $(c)/usr/lib/amanda/killpgrp \
                $(c)/usr/lib/amanda/rundump \
                $(c)/usr/lib/amanda/runtar \
@@ -107,6 +120,9 @@ binary-arch: build
                $(s)/usr/lib/amanda/planner \
                $(s)/usr/sbin/amcheck
        chmod u=srwx,g=rx,o=r \
+               $(c)/usr/lib/amanda/application/amgtar \
+               $(c)/usr/lib/amanda/application/amstar \
+               $(c)/usr/lib/amanda/calcsize \
                $(c)/usr/lib/amanda/killpgrp \
                $(c)/usr/lib/amanda/rundump \
                $(c)/usr/lib/amanda/runtar \
@@ -115,12 +131,13 @@ binary-arch: build
                $(s)/usr/sbin/amcheck
        install -o root -g root -m 0644 debian/amanda-client.lintian \
                $(c)/usr/share/lintian/overrides/amanda-client
-       install -o root -g root -m 0644 debian/amanda-common.lintian \
-               $(r)/usr/share/lintian/overrides/amanda-common
+#      install -o root -g root -m 0644 debian/amanda-common.lintian \
+#              $(r)/usr/share/lintian/overrides/amanda-common
        install -o root -g root -m 0644 debian/amanda-server.lintian \
                $(s)/usr/share/lintian/overrides/amanda-server
-       dh_makeshlibs -a
+       dh_makeshlibs -pamanda-common --noscripts
        dh_installdeb -a
+       dh_perl -a
        dh_shlibdeps -a -l"debian/amanda-common/usr/lib:debian/amanda-client/usr/lib:debian/amanda-server/usr/lib"
        # strip out the non-versioned amanda-common references, we need
        # the versioned ones in the control file and dupes are ugly...