add a prebuild target for use from git-buildpackage clean hook, that creates
[fw/altos] / debian / rules
index bf9827e1ff8b73ae217afda8402e393500c9924f..d576ab32acb9d339a8a162e1ee5e12a95fa07937 100755 (executable)
@@ -4,6 +4,11 @@
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)-.*/\1/p'| sed 's/+dfsg//')
 
+# this target invoked by git-buildpackage using a clean hook, see .gbp.conf
+prebuild:
+       dch -v `git describe | tr - +` "build for Debian from git"
+       git commit debian/changelog -m "update Debian changelog for build"
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir