move the ChangeLog creation to the prebuild target
[fw/altos] / debian / rules
index 54a6d241932483ec6bf0819405dc0937963f9940..ca1bb03ad57d5b8163eeb4ba6b6887a3240e6d17 100755 (executable)
@@ -8,6 +8,7 @@ PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
 prebuild:
        dch -v `git describe | tr - +` "build for Debian from git"
        git commit debian/changelog -m "update Debian changelog for build"
+       git log > ChangeLog
 
 configure: configure-stamp
 configure-stamp: