don't ship a zero-length ChangeLog, when it's easy to make one...
[fw/altos] / debian / rules
index 54a6d241932483ec6bf0819405dc0937963f9940..8ea2a60a74345e9b8f8ce7fe93bbb73290f15026 100755 (executable)
@@ -8,11 +8,13 @@ PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
 prebuild:
        dch -v `git describe | tr - +` "build for Debian from git"
        git commit debian/changelog -m "update Debian changelog for build"
+       
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        ./autogen.sh --prefix=/usr
+       make ChangeLog
        touch configure-stamp
 
 build: build-stamp