update changelog for Debian build
[fw/altos] / debian / rules
index 1353321d49be85562e4f5868a2b928992c24cd57..57c7e7426e9af07f360d9109e26bfefb0f09beac 100755 (executable)
@@ -3,22 +3,15 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
-DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; fi | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       echo $(DEB_VERSION)
-       git-dch --release --new-version=$(DEB_VERSION)
-       git log > ChangeLog
-       git commit -n ChangeLog debian/changelog \
-               -m "update changelogs for Debian build"
-       git tag debian/$(DEB_VERSION)
-#      git push --tags origin master
+       echo "not frobbing changelog for official builds"
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       ./autogen.sh --prefix=/usr
+       PKG_CONFIG_PATH=/opt/stlink/lib/pkgconfig ./autogen.sh --prefix=/usr
        touch configure-stamp
 
 build: build-arch build-indep
@@ -27,7 +20,7 @@ build-indep: build-stamp
 
 build-stamp: configure-stamp  
        dh_testdir
-       $(MAKE) VERSION=$(PKG_VERSION)
+       $(MAKE)
        (cd doc ; $(MAKE))
        touch $@