we need ChangeLog in the repo for git-buildpackage to work right
[fw/altos] / debian / rules
index 8ea2a60a74345e9b8f8ce7fe93bbb73290f15026..078dac56cddff93a9e91161cd046e1181d255b42 100755 (executable)
@@ -7,14 +7,14 @@ PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
        dch -v `git describe | tr - +` "build for Debian from git"
-       git commit debian/changelog -m "update Debian changelog for build"
-       
+       git log > ChangeLog
+       git commit ChangeLog debian/changelog \
+               -m "update changelogs for Debian build"
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        ./autogen.sh --prefix=/usr
-       make ChangeLog
        touch configure-stamp
 
 build: build-stamp