Imported Debian patch 0.1beta-19 debian/0.1beta-19
authorBdale Garbee <bdale@gag.com>
Mon, 21 Aug 2006 06:24:12 +0000 (00:24 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:41:08 +0000 (17:41 -0600)
config.h
debian/changelog
debian/compat
debian/control

index 571924713bff44e99419d59e0affb31d791be5a2..67142318b6eaa297944887ae8ea0a1632c3acedf 100644 (file)
--- a/config.h
+++ b/config.h
  * it if your machine is big-endian (e.g. Motorola, Sparc...)
  * Note that some compilers have LITTLE_ENDIAN yet defined.
  */
-#if __BYTE_ORDER == __LITTLE_ENDIAN
+#ifndef LITTLE_ENDIAN
+# if __BYTE_ORDER == __LITTLE_ENDIAN
 #      define LITTLE_ENDIAN
-#else
+# else
 #      undef  LITTLE_ENDIAN
+# endif
 #endif
 
 /* When DCELL_MEM is defined, double cell transfer is realized by memory
index 604b0174cad992c82db6b36e6afe115056bf94bf..f1ddb68b1c69b1d74ddc2c93a9ad44bb1de80182 100644 (file)
@@ -1,3 +1,10 @@
+yforth (0.1beta-19) unstable; urgency=low
+
+  * add kfreebsd-amd64 to architecture list, closes: #361634
+  * avoid duplicate definition for LITTLE_ENDIAN
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 21 Aug 2006 00:24:12 -0600
+
 yforth (0.1beta-18) unstable; urgency=low
 
   * add kfreebsd-i386 to list of architectures to build on, closes: #315050
index b8626c4cff2849624fb67f87cd0ad72b163671ad..7ed6ff82de6bcc2a78243fc9c54d3ef5ac14da69 100644 (file)
@@ -1 +1 @@
-4
+5
index 514d1259dc67ebc218b2d37e0762a572d2c37219..dfe9676d4b34ec1120477b89e5480e0cd2d49f15 100644 (file)
@@ -2,11 +2,11 @@ Source: yforth
 Section: interpreters
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 4)
-Standards-Version: 3.6.2.1
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.7.2
 
 Package: yforth
-Architecture: alpha amd64 arm i386 kfreebsd-i386 m68k powerpc ppc64 sparc
+Architecture: alpha amd64 arm i386 kfreebsd-i386 kfreebsd-amd64 m68k powerpc ppc64 sparc
 Depends: ${shlibs:Depends}
 Description: A small freeware Forth environment in ANSI C
  yForth? is an interestingly small implementation of Forth for Linux.  It