fix things lintian whines about debian/0.1beta-22
authorBdale Garbee <bdale@gag.com>
Tue, 18 Oct 2011 04:30:16 +0000 (00:30 -0400)
committerBdale Garbee <bdale@gag.com>
Tue, 18 Oct 2011 04:30:16 +0000 (00:30 -0400)
debian/control
debian/rules

index 35b5a2c3465af9ddd798963476932a09d6867908..8915cb7f369aedd62f569959df6dbef34af2a09a 100644 (file)
@@ -3,14 +3,14 @@ Section: interpreters
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Depends: debhelper (>= 5)
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Depends: debhelper (>= 5)
-Standards-Version: 3.8.4
+Standards-Version: 3.9.2
 Vcs-Git: git://git.gag.com/debian/yforth
 Vcs-Browser: http://git.gag.com/?p=debian/yforth
 
 Package: yforth
 Architecture: any
 Vcs-Git: git://git.gag.com/debian/yforth
 Vcs-Browser: http://git.gag.com/?p=debian/yforth
 
 Package: yforth
 Architecture: any
-Depends: ${shlibs:Depends}
-Description: small freeware Forth environment in ANSI C
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: small freeware Forth environment in ANSI C
  yForth? is an interestingly small implementation of Forth for Linux.  It
  suffers several deficiencies.  For general Forth programming or learning 
  under Linux, yForth? is not the best choice.
  yForth? is an interestingly small implementation of Forth for Linux.  It
  suffers several deficiencies.  For general Forth programming or learning 
  under Linux, yForth? is not the best choice.
index f890e6d1a3e58ccb6fd5988d5b1be4792d48d96a..6f116eaeccfc80b934638eac1b957a5f16f80f21 100755 (executable)
@@ -5,7 +5,9 @@
 
 export DH_VERBOSE=1
 
 
 export DH_VERBOSE=1
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 build-stamp:
        dh_testdir
        $(MAKE)
 build-stamp:
        dh_testdir
        $(MAKE)
@@ -47,4 +49,4 @@ source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
 binary: binary-indep binary-arch
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build clean binary-indep binary-arch binary build-arch build-indep