Imported Upstream version 0.2.1 upstream upstream/0.2.1
authorBdale Garbee <bdale@gag.com>
Thu, 11 Oct 2012 15:02:15 +0000 (09:02 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 11 Oct 2012 15:02:15 +0000 (09:02 -0600)
Makefile
ver.h

index 5e0fddb08bc741a61c4222653e91f7ff79a7e358..ea23ce45d3189588480922880aad724ecf979547 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-OPTIMIZE = -O2
 CC = gcc
 MATHLIB = -lm
 
@@ -13,16 +12,16 @@ INCLUDES = block.h blocke.h config.h core.h coree.h defaults.h double.h \
        string.h tools.h toolse.h udio.h ver.h ycore.h yforth.h 
 
 yforth: div.h $(OBJECTS)
-       $(CC) -o yforth $(OBJECTS) $(MATHLIB)
+       $(CC) -o yforth $(LDFLAGS) $(OBJECTS) $(MATHLIB)
 
 div.h: div
        ./div 
        
 div: division.c
-       $(CC) -o div division.c
+       $(CC) -o div $(CFLAGS) $(CPPFLAGS) division.c
 
 .c.o:   
-       $(CC) -c -o $@ $(OPTIMIZE) $<
+       $(CC) -c -o $@ $(CFLAGS) $(CPPFLAGS) $<
 
 clean:
        rm -f *.o yforth div.h div 
diff --git a/ver.h b/ver.h
index 37829062d31e7d198edb73122bd2e3276fac3cc2..cfddc40c8d97240dfa9f2f010f805da978e27198 100644 (file)
--- a/ver.h
+++ b/ver.h
@@ -20,5 +20,5 @@
 
 #define VER_HI                 0
 #define        VER_LO                  2
-#define VER_TEST               "+beta"
+#define VER_TEST               ""