hardening build flags patch from Mortiz Muehlenhoff
authorBdale Garbee <bdale@gag.com>
Fri, 30 Dec 2011 16:18:38 +0000 (09:18 -0700)
committerBdale Garbee <bdale@gag.com>
Fri, 30 Dec 2011 16:18:38 +0000 (09:18 -0700)
debian/changelog
debian/rules

index 4039b5f32bb19d2e4cff03cb1422a8df10e15a40..b53c50cbe78ef63248052dc4b46356d9352fdcd1 100644 (file)
@@ -1,8 +1,9 @@
 tar (1.26-4) UNRELEASED; urgency=low
 
   * mark "Mult-Arch: foreign" to ease crossgrading, closes: #649478
+  * hardened build flags patch from Moritz Huehlenhoff, closes: #653722
 
- -- Bdale Garbee <bdale@gag.com>  Mon, 21 Nov 2011 08:03:32 -0700
+ -- Bdale Garbee <bdale@gag.com>  Fri, 30 Dec 2011 09:18:11 -0700
 
 tar (1.26-3) unstable; urgency=low
 
index 2dbe218722f84549e986bf226bc4d14aaf40bc07..d978367b9c6f3ca1b9e719c8cbee497000db373b 100755 (executable)
@@ -6,12 +6,17 @@ ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
 CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
 endif
 
+CFLAGS = `dpkg-buildflags --get CFLAGS`
+CFLAGS += -Wall
+LDFLAGS += `dpkg-buildflags --get LDFLAGS`
+CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        cp -f /usr/share/misc/config.sub build-aux/config.sub
        cp -f /usr/share/misc/config.guess build-aux/config.guess
-       RSH="/usr/bin/rsh" CFLAGS="-O2 -g -Wall" ./configure \
+       RSH="/usr/bin/rsh" CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure \
                --prefix=/usr \
                --libexecdir=/usr/sbin \
                --with-lzma=xz \