move secure_path from configure to sudoers
authorBdale Garbee <bdale@gag.com>
Fri, 22 Jul 2011 13:23:29 +0000 (15:23 +0200)
committerBdale Garbee <bdale@gag.com>
Fri, 22 Jul 2011 13:23:29 +0000 (15:23 +0200)
debian/changelog
debian/patches/env.c-safety.diff [deleted file]
debian/patches/series
debian/rules
debian/sudoers

index 8d9830b3b17282b9e8f0fd867a45e88d48940b3f..0a6eb119b8e6409b25e959d13b66ff98529ab6b0 100644 (file)
@@ -2,8 +2,9 @@ sudo (1.8.1p2-1) UNRELEASED; urgency=low
 
   * new upstream version
   * include common-session in pam config, closes: #519700, #607199
+  * move secure_path from configure to default sudoers, closes: #85123, 85917
 
- -- Bdale Garbee <bdale@gag.com>  Fri, 22 Jul 2011 14:51:28 +0200
+ -- Bdale Garbee <bdale@gag.com>  Fri, 22 Jul 2011 15:22:40 +0200
 
 sudo (1.7.4p6-1) unstable; urgency=low
 
diff --git a/debian/patches/env.c-safety.diff b/debian/patches/env.c-safety.diff
deleted file mode 100644 (file)
index 034dfdb..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
---- /home/bdale/Desktop/sudo-1.7.2p1/env.c     2009-06-23 12:24:42.000000000 -0600
-+++ sudo/env.c 2009-11-20 07:31:58.000000000 -0700
-@@ -120,6 +120,8 @@
- static const char *initial_badenv_table[] = {
-     "IFS",
-     "CDPATH",
-+    "SHELLOPTS",
-+    "PS4",
-     "LOCALDOMAIN",
-     "RES_OPTIONS",
-     "HOSTALIASES",
-@@ -602,6 +604,17 @@
-           if (keepit == -1)
-               keepit = matches_env_keep(*ep);
-+          if (!strncmp (*ep, "DISPLAY=",8)
-+              || !strncmp (*ep, "XAUTHORITY=", 11)
-+              || !strncmp (*ep, "XAUTHORIZATION=", 15)
-+              || !strncmp (*ep, "XAPPLRESDIR=", 12)
-+              || !strncmp (*ep, "XFILESEARCHPATH=", 16)
-+              || !strncmp (*ep, "XUSERFILESEARCHPATH=", 20)
-+              || !strncmp (*ep, "LANG=", 5)
-+              || !strncmp (*ep, "LANGUAGE=", 9)
-+              || !strncmp (*ep, "LC_", 3))
-+            keepit = 1;
-+
-           /* For SUDO_PS1 -> PS1 conversion. */
-           if (strncmp(*ep, "SUDO_PS1=", 8) == 0)
-               ps1 = *ep + 5;
---- tmp/sudoers.pod    2010-03-11 12:28:58.000000000 -0700
-+++ sudo/sudoers.pod   2010-03-11 12:29:58.000000000 -0700
-@@ -1227,6 +1227,9 @@
- =item env_delete
-+Not effective due to security issues: only variables listed in 
-+I<env_keep> or I<env_check> can be passed through B<sudo>!
-+
- Environment variables to be removed from the user's environment
- when the I<env_reset> option is not in effect.  The argument may
- be a double-quoted, space-separated list or a single value without
-@@ -1240,8 +1243,8 @@
- =item env_keep
--Environment variables to be preserved in the user's environment
--when the I<env_reset> option is in effect.  This allows fine-grained
-+Environment variables to be preserved in the user's environment.
-+This allows fine-grained
- control over the environment B<sudo>-spawned processes will receive.
- The argument may be a double-quoted, space-separated list or a
- single value without double-quotes.  The list can be replaced, added
---- a/sudo.pod
-+++ b/sudo.pod
-@@ -456,8 +456,8 @@ and, as such, it is not possible for B<sudo> to preserve them.
- To prevent command spoofing, B<sudo> checks "." and "" (both denoting
- current directory) last when searching for a command in the user's
- PATH (if one or both are in the PATH).  Note, however, that the
--actual C<PATH> environment variable is I<not> modified and is passed
--unchanged to the program that B<sudo> executes.
-+C<PATH> environment variable is further modified in Debian because of
-+the use of the I<SECURE_PATH> build option.
- B<sudo> will check the ownership of its time stamp directory
- (F<@timedir@> by default) and ignore the directory's contents if
index 178a4c4eac63eaace4c0b6fec4f4559badb3cbf5..5e1f561771fda7cd2b9842f5e461c94ed29d302d 100644 (file)
@@ -1,3 +1,2 @@
 typo-in-classic-insults.diff
-env.c-safety.diff
 paths-in-samples.diff
index 2f665ff5cfae8519f99f68031f7c8aa9dfa4ab87..6c063205f92e05b87f5c2e69f719b69d2fcfd8e0 100755 (executable)
@@ -36,8 +36,7 @@ configure-stamp:
                --disable-setresuid \
                --with-sendmail=/usr/sbin/sendmail \
                --mandir=/usr/share/man \
-               --libexecdir=/usr/lib/sudo \
-               --with-secure-path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin"
+               --libexecdir=/usr/lib/sudo
 
        # LDAP version
        mkdir -p build-ldap
index 4cecb43c5c2afa89da8e6c85631fec685320c484..1f732434060c4bf193bf6bb2fa8b5ea93db107ac 100644 (file)
@@ -7,6 +7,7 @@
 # See the man page for details on how to write a sudoers file.
 #
 Defaults       env_reset
+Defaults       secure_path     "/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin"
 
 # Host alias specification