Imported Upstream version 1.7.4p6 upstream/1.7.4p6
authorBdale Garbee <bdale@gag.com>
Wed, 9 Feb 2011 18:23:58 +0000 (11:23 -0700)
committerBdale Garbee <bdale@gag.com>
Wed, 9 Feb 2011 18:23:58 +0000 (11:23 -0700)
ChangeLog
NEWS
configure
configure.in
term.c

index 69c48b76bde845d6b19f17b098e7589317795b2d..b0e2b30ad0422f90c937d1d0094b872e1f895a13 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2011-01-18  Todd C. Miller  <Todd.Miller@courtesan.com>
+
+       * term.c:
+       Clear, don't set, OPOST in c_oflag as was intended in e26055d17b72.
+       [eacd774c37c0]
+
 2011-01-11  Todd C. Miller  <Todd.Miller@courtesan.com>
 
        * check.c:
diff --git a/NEWS b/NEWS
index ffb6d78167928fe38d53fc6d33bc61a080d8f9f6..71be281c3210fefcd38ae6eac430eb05d9de7c85 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,8 @@
+What's new in Sudo 1.7.4p6?
+
+ * A bug has been fixed in the I/O logging support that could cause
+   visual artifacts in full-screen programs such as text editors.
+
 What's new in Sudo 1.7.4p5?
 
  * A bug has been fixed that would allow a command to be run without the
@@ -9,9 +14,6 @@ What's new in Sudo 1.7.4p5?
  * A crash has been fixed when sudo's -g flag is used without the -u flag
    and the sudoers file contains an entry with no runas user or group listed.
 
- * A bug has been fixed in the I/O logging support that could cause
-   visual artifacts in full-screen programs such as text editors,.
-
  * A crash has been fixed when the Solaris project support is enabled
    and sudo's -g flag is used without the -u flag.
 
index 209de36edce3bebd8a9769fbf5b11d8862a311b2..f7c4838c0780cc49bac5e4e7dae4b5b26f5a8a46 100755 (executable)
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.65 for sudo 1.7.4p5.
+# Generated by GNU Autoconf 2.65 for sudo 1.7.4p6.
 #
 # Report bugs to <http://www.sudo.ws/bugs/>.
 #
@@ -701,8 +701,8 @@ MAKEFLAGS=
 # Identity of this package.
 PACKAGE_NAME='sudo'
 PACKAGE_TARNAME='sudo'
-PACKAGE_VERSION='1.7.4p5'
-PACKAGE_STRING='sudo 1.7.4p5'
+PACKAGE_VERSION='1.7.4p6'
+PACKAGE_STRING='sudo 1.7.4p6'
 PACKAGE_BUGREPORT='http://www.sudo.ws/bugs/'
 PACKAGE_URL=''
 
@@ -1552,7 +1552,7 @@ if test "$ac_init_help" = "long"; then
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures sudo 1.7.4p5 to adapt to many kinds of systems.
+\`configure' configures sudo 1.7.4p6 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1617,7 +1617,7 @@ fi
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
-     short | recursive ) echo "Configuration of sudo 1.7.4p5:";;
+     short | recursive ) echo "Configuration of sudo 1.7.4p6:";;
    esac
   cat <<\_ACEOF
 
@@ -1828,7 +1828,7 @@ fi
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-sudo configure 1.7.4p5
+sudo configure 1.7.4p6
 generated by GNU Autoconf 2.65
 
 Copyright (C) 2009 Free Software Foundation, Inc.
@@ -2527,7 +2527,7 @@ cat >config.log <<_ACEOF
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by sudo $as_me 1.7.4p5, which was
+It was created by sudo $as_me 1.7.4p6, which was
 generated by GNU Autoconf 2.65.  Invocation command line was
 
   $ $0 $@
@@ -18977,7 +18977,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by sudo $as_me 1.7.4p5, which was
+This file was extended by sudo $as_me 1.7.4p6, which was
 generated by GNU Autoconf 2.65.  Invocation command line was
 
   CONFIG_FILES    = $CONFIG_FILES
@@ -19043,7 +19043,7 @@ _ACEOF
 cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
 ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
 ac_cs_version="\\
-sudo config.status 1.7.4p5
+sudo config.status 1.7.4p6
 configured by $0, generated by GNU Autoconf 2.65,
   with options \\"\$ac_cs_config\\"
 
index aed2ff0bbdf1ce98031d95ce5940600b4cf8cde7..04ae0741585e67c02cc9bed616a182e70dbd8ed7 100644 (file)
@@ -3,7 +3,7 @@ dnl Process this file with GNU autoconf to produce a configure script.
 dnl
 dnl Copyright (c) 1994-1996,1998-2010 Todd C. Miller <Todd.Miller@courtesan.com>
 dnl
-AC_INIT([sudo], [1.7.4p5], [http://www.sudo.ws/bugs/], [sudo])
+AC_INIT([sudo], [1.7.4p6], [http://www.sudo.ws/bugs/], [sudo])
 AC_CONFIG_HEADER(config.h pathnames.h)
 dnl
 dnl This won't work before AC_INIT
diff --git a/term.c b/term.c
index b1e9da65f07efb24f69578fcf67a7259519587d5..85b730092deb00f2313bd7d66b1608b3e88f91e8 100644 (file)
--- a/term.c
+++ b/term.c
@@ -152,7 +152,7 @@ term_raw(fd, isig)
     term.c_cc[VMIN] = 1;
     term.c_cc[VTIME] = 0;
     CLR(term.c_iflag, ICRNL | IGNCR | INLCR | IUCLC | IXON);
-    SET(term.c_oflag, OPOST);
+    CLR(term.c_oflag, OPOST);
     CLR(term.c_lflag, ECHO | ICANON | ISIG | IEXTEN);
     if (isig)
        SET(term.c_lflag, ISIG);