Imported Debian patch 1.6.8p9-4 debian/1.6.8p9-4
authorBdale Garbee <bdale@gag.com>
Sat, 10 Dec 2005 15:47:07 +0000 (07:47 -0800)
committerBdale Garbee <bdale@gag.com>
Wed, 14 May 2008 18:03:43 +0000 (12:03 -0600)
debian/OPTIONS
debian/changelog
debian/control
debian/docs [new file with mode: 0644]
debian/init.d
debian/rules

index 919eee6dd90d9870074e4d9779502ddab3531b99..4f98523b3bca4df6c45bd63ae1b205a389aa2023 100644 (file)
@@ -10,6 +10,10 @@ The following options were used to configure sudo for Debian GNU/Linux.
        
        Support for pluggable authentication modules.
 
+  --with-ldap
+
+       Support for LDAP authentication.
+
   --with-fqdn 
 
        Allow use of fully qualified domain names in the sudoers file.
@@ -47,3 +51,11 @@ The following options were used to configure sudo for Debian GNU/Linux.
        Include all the insults in the binary, won't be enabled unless turned
        on in the sudoers file.
 
+  --with-sendmail=/usr/sbin/sendmail
+
+       Use Debian policy to know the location of sendmail instead of trying 
+       to detect it at build time.
+
+  --disable-setresuid
+
+       Linux 2.2 kernels don't support setresgid.
index 6e03cab0529b464db66733f5e2b0d79c3c7716a8..98086a3c6a44e22b9e0d1380dcd1db4ea7cba31e 100644 (file)
@@ -1,3 +1,12 @@
+sudo (1.6.8p9-4) unstable; urgency=low
+
+  * enable ldap support, deliver README.LDAP and sudoers2ldif, closes: #283231 
+  * merge patch from Martin Pitt / Ubuntu to be more robust about resetting
+    timestamps in the init.d script, closes: #330868
+  * add dependency header to init.d script, closes: #332849
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 10 Dec 2005 07:47:07 -0800
+
 sudo (1.6.8p9-3) unstable; urgency=high
 
   * update debhelper compatibility level from 2 to 4
index 56cf44fbe587f932899fea91b72e19d2ae944f6d..4e0328314623cfd3402d84f1216b0e67b2e532f2 100644 (file)
@@ -2,7 +2,7 @@ Source: sudo
 Section: admin
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 4), libpam0g-dev
+Build-Depends: debhelper (>= 5), libpam0g-dev, libldap2-dev
 Standards-Version: 3.6.2.1
 
 Package: sudo
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..bafbded
--- /dev/null
@@ -0,0 +1,11 @@
+debian/OPTIONS 
+BUGS 
+RUNSON 
+UPGRADE 
+PORTING
+TODO 
+HISTORY 
+README 
+README.LDAP 
+TROUBLESHOOTING
+sudoers2ldif
index 85f1b190fa875def7e45699a16668c86f3a3a464..ba6725520c3aa75ac289ffce8916d70bde9ba641 100644 (file)
@@ -1,5 +1,13 @@
 #! /bin/sh
 
+### BEGIN INIT INFO
+# Provides:          sudu
+# Required-Start:    $local_fs $remote_fs
+# Required-Stop:
+# Default-Start:     S 1 2 3 4 5
+# Default-Stop:      0 6
+### END INIT INFO
+
 N=/etc/init.d/sudo
 
 set -e
@@ -7,9 +15,9 @@ set -e
 case "$1" in
   start)
        # make sure privileges don't persist across reboots
-       if [ -d /var/run/sudo ] && [ "x`ls /var/run/sudo`" != x ]
+       if [ -d /var/run/sudo ]
        then
-               touch -t 198501010000 /var/run/sudo/*
+                find /var/run/sudo -type f -exec touch -t 198501010000 '{}' \;
        fi
        ;;
   stop|reload|restart|force-reload)
index a5a2a125da19df4f36e797f4b082ab1b19fe2d67..5529cf35466840417c46282b14265d94f4f650f7 100755 (executable)
@@ -15,7 +15,7 @@ build-stamp:
 
        ./configure --prefix=/usr -v \
                --with-all-insults \
-               --with-exempt=sudo --with-pam --with-fqdn \
+               --with-exempt=sudo --with-pam --with-ldap --with-fqdn \
                --with-logging=syslog --with-logfac=authpriv \
                --with-env-editor --with-editor=/usr/bin/editor \
                --with-timeout=15 --with-password-timeout=0 \
@@ -70,8 +70,7 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installdocs debian/OPTIONS BUGS RUNSON UPGRADE PORTING \
-               TODO HISTORY README TROUBLESHOOTING
+       dh_installdocs
        dh_installexamples
        dh_installmenu
        dh_installinit