add systemd service file provided by Michael Stapelberg
authorBdale Garbee <bdale@gag.com>
Wed, 11 Jan 2012 19:39:09 +0000 (12:39 -0700)
committerBdale Garbee <bdale@gag.com>
Wed, 11 Jan 2012 19:39:09 +0000 (12:39 -0700)
debian/changelog
debian/rules
debian/sudo-ldap.dirs
debian/sudo.dirs
debian/sudo.service [new file with mode: 0644]

index fbff225ca96c963bcf677cd9435d0b475a798f29..d78c69becb5e66d821f89392436938a1da486ec0 100644 (file)
@@ -1,3 +1,11 @@
+sudo (1.8.3p1-3) unstable; urgency=low
+
+  * patch from Moritz Muehlenhoff enables hardened build flags, closes: #655417
+  * replacement postinst script from Mike Beattie using shell instead of Perl
+  * include systemd service file from Michael Stapelberg, closes: #639633
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 11 Jan 2012 12:38:28 -0700
+
 sudo (1.8.3p1-2) unstable; urgency=low
 
   * if upgrading from squeeze, and the sudoers file is unmodified, avoid
index adf2947d8dcce15a884a8a974f5f43fe91f2a45d..b744a68318ef01caf683bd55dcee9d59b1307cba 100755 (executable)
@@ -130,6 +130,11 @@ install: build-stamp
        install -o root -g root -m 0440 debian/README \
                debian/sudo-ldap/etc/sudoers.d/README
 
+       install -o root -g root -m 0644 debian/sudo.service \
+               debian/sudo/lib/systemd/system/sudo.service
+       install -o root -g root -m 0644 debian/sudo.service \
+               debian/sudo-ldap/lib/systemd/system/sudo.service
+
 binary-indep: build install
 
 binary-arch: build install
index 83f817ca9a646cdfb608972622698640f78ada08..ae54a525a18e586c4d9e5a78c79b9fca7bf6af0a 100644 (file)
@@ -1,5 +1,6 @@
 etc/pam.d
 etc/sudoers.d
+lib/systemd/system
 usr/bin
 usr/share/man/man8
 usr/share/man/man5
index 4d15db41ab92391cb950e1b52959fa424ce405c9..f1e6b2328bf91f9236ccc94042313b71c89c13e4 100644 (file)
@@ -1,5 +1,6 @@
 etc/pam.d
 etc/sudoers.d
+lib/systemd/system
 usr/bin
 usr/share/man/man8
 usr/share/man/man5
diff --git a/debian/sudo.service b/debian/sudo.service
new file mode 100644 (file)
index 0000000..664d855
--- /dev/null
@@ -0,0 +1,10 @@
+[Unit]
+Description=Provide limited super user privileges to specific users
+
+[Service]
+Type=oneshot
+# \073 is ';' which needs to be part of the find parameters
+ExecStart=/usr/bin/find /var/lib/sudo -exec /usr/bin/touch -t 198501010000 '{}' \073
+
+[Install]
+WantedBy=multi-user.target