update patch to reflect changes in new upstream version
authorBdale Garbee <bdale@gag.com>
Wed, 16 May 2012 16:36:44 +0000 (10:36 -0600)
committerBdale Garbee <bdale@gag.com>
Wed, 16 May 2012 16:36:44 +0000 (10:36 -0600)
debian/patches/actually-use-buildflags.diff

index 42bf4b592a81a1d39936b28e798739d4ff1a412f..f1b7297bd2ea6d09976702292c6b126cb34c18a0 100644 (file)
@@ -1,26 +1,31 @@
-Description: Use build flags from environment (dpkg-buildflags).
- Necessary for hardening flags.
-Author: Simon Ruderich <simon@ruderich.org>
-Last-Update: 2012-03-13
-
-Index: sudo-1.8.3p2/src/Makefile.in
-===================================================================
---- sudo-1.8.3p2.orig/src/Makefile.in  2012-03-13 17:46:43.069036559 +0100
-+++ sudo-1.8.3p2/src/Makefile.in       2012-03-13 17:47:12.949037698 +0100
-@@ -101,7 +101,7 @@
-       $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(LTLDFLAGS) -o $@ sudo_noexec.lo -avoid-version -rpath $(noexecdir)
- sesh: sesh.o
--      $(CC) -o $@ sesh.o
-+      $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ sesh.o
+diff --git a/common/Makefile.in b/common/Makefile.in
+index aff4c54..7f05e4b 100644
+--- a/common/Makefile.in
++++ b/common/Makefile.in
+@@ -45,6 +45,9 @@ CPPFLAGS = -I$(incdir) -I$(top_builddir) -I$(top_srcdir) @CPPFLAGS@
+ # Usually -O and/or -g
+ CFLAGS = @CFLAGS@
++# Linker flags
++LDFLAGS = @LDFLAGS@
++
+ # OS dependent defines
+ DEFS = @OSDEFS@ -D_PATH_SUDO_CONF=\"$(sysconfdir)/sudo.conf\"
+@@ -67,7 +70,7 @@ Makefile: $(srcdir)/Makefile.in
+       $(LIBTOOL) --mode=compile $(CC) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(DEFS) $<
+ libcommon.la: $(LTOBJS)
+-      $(LIBTOOL) --mode=link $(CC) -o $@ $(LTOBJS) -no-install
++      $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(LTOBJS) -no-install
  
  pre-install:
  
-Index: sudo-1.8.3p2/compat/Makefile.in
-===================================================================
---- sudo-1.8.3p2.orig/compat/Makefile.in       2012-03-13 17:46:43.069036559 +0100
-+++ sudo-1.8.3p2/compat/Makefile.in    2012-03-13 17:47:12.949037698 +0100
-@@ -35,6 +35,9 @@
+diff --git a/compat/Makefile.in b/compat/Makefile.in
+index d0361ce..93672ac 100644
+--- a/compat/Makefile.in
++++ b/compat/Makefile.in
+@@ -45,6 +45,9 @@ CPPFLAGS = -I$(incdir) -I$(top_builddir) -I$(top_srcdir) @CPPFLAGS@
  # Usually -O and/or -g
  CFLAGS = @CFLAGS@
  
@@ -30,7 +35,7 @@ Index: sudo-1.8.3p2/compat/Makefile.in
  # OS dependent defines
  DEFS = @OSDEFS@
  
-@@ -62,19 +65,19 @@
+@@ -75,19 +78,19 @@ Makefile: $(srcdir)/Makefile.in
        $(LIBTOOL) --mode=compile $(CC) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(DEFS) $<
  
  libreplace.la: $(LTLIBOBJS)
@@ -52,36 +57,120 @@ Index: sudo-1.8.3p2/compat/Makefile.in
 -      $(LIBTOOL) --mode=link $(CC) -o $@ globtest.o libreplace.la
 +      $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ globtest.o libreplace.la
  
- @DEV@$(srcdir)/mksiglist.h: $(srcdir)/siglist.in
- @DEV@ awk 'BEGIN {print "/* public domain */\n"} /^    [A-Z]/ {printf("#ifdef SIG%s\n    if (my_sys_siglist[SIG%s] == NULL)\n\tmy_sys_siglist[SIG%s] = \"%s\";\n#endif\n", $$1, $$1, $$1, substr($$0, 13))}' < $(srcdir)/siglist.in > $@
-Index: sudo-1.8.3p2/common/Makefile.in
-===================================================================
---- sudo-1.8.3p2.orig/common/Makefile.in       2012-03-13 17:46:43.013036558 +0100
-+++ sudo-1.8.3p2/common/Makefile.in    2012-03-13 17:47:12.949037698 +0100
-@@ -35,6 +35,9 @@
+ $(srcdir)/mksiglist.h: $(srcdir)/siglist.in
+       if [ -n "$(DEVEL)" ]; then \
+diff --git a/debian/patches/actually-use-buildflags.diff b/debian/patches/actually-use-buildflags.diff
+index 42bf4b5..e69de29 100644
+--- a/debian/patches/actually-use-buildflags.diff
++++ b/debian/patches/actually-use-buildflags.diff
+@@ -1,92 +0,0 @@
+-Description: Use build flags from environment (dpkg-buildflags).
+- Necessary for hardening flags.
+-Author: Simon Ruderich <simon@ruderich.org>
+-Last-Update: 2012-03-13
+-
+-Index: sudo-1.8.3p2/src/Makefile.in
+-===================================================================
+---- sudo-1.8.3p2.orig/src/Makefile.in 2012-03-13 17:46:43.069036559 +0100
+-+++ sudo-1.8.3p2/src/Makefile.in      2012-03-13 17:47:12.949037698 +0100
+-@@ -101,7 +101,7 @@
+-      $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(LTLDFLAGS) -o $@ sudo_noexec.lo -avoid-version -rpath $(noexecdir)
+- 
+- sesh: sesh.o
+--     $(CC) -o $@ sesh.o
+-+     $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ sesh.o
+- 
+- pre-install:
+- 
+-Index: sudo-1.8.3p2/compat/Makefile.in
+-===================================================================
+---- sudo-1.8.3p2.orig/compat/Makefile.in      2012-03-13 17:46:43.069036559 +0100
+-+++ sudo-1.8.3p2/compat/Makefile.in   2012-03-13 17:47:12.949037698 +0100
+-@@ -35,6 +35,9 @@
+- # Usually -O and/or -g
+- CFLAGS = @CFLAGS@
+- 
+-+# Linker flags
+-+LDFLAGS = @LDFLAGS@
+-+
+- # OS dependent defines
+- DEFS = @OSDEFS@
+- 
+-@@ -62,19 +65,19 @@
+-      $(LIBTOOL) --mode=compile $(CC) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(DEFS) $<
+- 
+- libreplace.la: $(LTLIBOBJS)
+--     $(LIBTOOL) --mode=link $(CC) -o $@ $(LTLIBOBJS) -no-install
+-+     $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(LTLIBOBJS) -no-install
+- 
+- siglist.c: mksiglist
+-      ./mksiglist > $@
+- 
+- mksiglist: $(srcdir)/mksiglist.c $(srcdir)/mksiglist.h $(incdir)/missing.h $(top_builddir)/config.h
+--     $(CC) $(CPPFLAGS) $(CFLAGS) $(DEFS) $(srcdir)/mksiglist.c -o $@
+-+     $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(DEFS) $(srcdir)/mksiglist.c -o $@
+- 
+- fnm_test: fnm_test.o libreplace.la
+--     $(LIBTOOL) --mode=link $(CC) -o $@ fnm_test.o libreplace.la
+-+     $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ fnm_test.o libreplace.la
+- 
+- globtest: globtest.o libreplace.la
+--     $(LIBTOOL) --mode=link $(CC) -o $@ globtest.o libreplace.la
+-+     $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ globtest.o libreplace.la
+- 
+- @DEV@$(srcdir)/mksiglist.h: $(srcdir)/siglist.in
+- @DEV@        awk 'BEGIN {print "/* public domain */\n"} /^    [A-Z]/ {printf("#ifdef SIG%s\n    if (my_sys_siglist[SIG%s] == NULL)\n\tmy_sys_siglist[SIG%s] = \"%s\";\n#endif\n", $$1, $$1, $$1, substr($$0, 13))}' < $(srcdir)/siglist.in > $@
+-Index: sudo-1.8.3p2/common/Makefile.in
+-===================================================================
+---- sudo-1.8.3p2.orig/common/Makefile.in      2012-03-13 17:46:43.013036558 +0100
+-+++ sudo-1.8.3p2/common/Makefile.in   2012-03-13 17:47:12.949037698 +0100
+-@@ -35,6 +35,9 @@
+- # Usually -O and/or -g
+- CFLAGS = @CFLAGS@
+- 
+-+# Linker flags
+-+LDFLAGS = @LDFLAGS@
+-+
+- # OS dependent defines
+- DEFS = @OSDEFS@
+- 
+-@@ -56,7 +59,7 @@
+-      $(LIBTOOL) --mode=compile $(CC) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(DEFS) $<
+- 
+- libcommon.la: $(LTOBJS)
+--     $(LIBTOOL) --mode=link $(CC) -o $@ $(LTOBJS) -no-install
+-+     $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(LTOBJS) -no-install
+- 
+- pre-install:
+- 
+-Index: sudo-1.8.3p2/plugins/sudoers/Makefile.in
+-===================================================================
+---- sudo-1.8.3p2.orig/plugins/sudoers/Makefile.in     2012-03-13 17:46:42.985036557 +0100
+-+++ sudo-1.8.3p2/plugins/sudoers/Makefile.in  2012-03-13 17:47:12.949037698 +0100
+-@@ -159,7 +159,7 @@
+-      (cd $(top_builddir) && ./config.status --file plugins/sudoers/Makefile)
+- 
+- libparsesudoers.la: $(LIBPARSESUDOERS_OBJS)
+--     $(LIBTOOL) --mode=link $(CC) -o $@ $(LIBPARSESUDOERS_OBJS) -no-install
+-+     $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(LIBPARSESUDOERS_OBJS) -no-install
+- 
+- sudoers.la: $(SUDOERS_OBJS) $(LT_LIBS) libparsesudoers.la
+-      $(LIBTOOL) @LT_STATIC@ --mode=link $(CC) $(SUDOERS_LDFLAGS) $(LTLDFLAGS) -o $@ $(SUDOERS_OBJS) libparsesudoers.la $(SUDOERS_LIBS) -module -export-symbols $(srcdir)/sudoers.sym -avoid-version -rpath $(plugindir)
+diff --git a/plugins/sudoers/Makefile.in b/plugins/sudoers/Makefile.in
+index 8769d38..0eb71e9 100644
+--- a/plugins/sudoers/Makefile.in
++++ b/plugins/sudoers/Makefile.in
+@@ -56,6 +56,9 @@ CPPFLAGS = -I$(incdir) -I$(top_builddir) -I$(devdir) -I$(srcdir) -I$(top_srcdir)
  # Usually -O and/or -g
  CFLAGS = @CFLAGS@
  
 +# Linker flags
 +LDFLAGS = @LDFLAGS@
 +
- # OS dependent defines
- DEFS = @OSDEFS@
-@@ -56,7 +59,7 @@
-       $(LIBTOOL) --mode=compile $(CC) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(DEFS) $<
- libcommon.la: $(LTOBJS)
--      $(LIBTOOL) --mode=link $(CC) -o $@ $(LTOBJS) -no-install
-+      $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(LTOBJS) -no-install
- pre-install:
-Index: sudo-1.8.3p2/plugins/sudoers/Makefile.in
-===================================================================
---- sudo-1.8.3p2.orig/plugins/sudoers/Makefile.in      2012-03-13 17:46:42.985036557 +0100
-+++ sudo-1.8.3p2/plugins/sudoers/Makefile.in   2012-03-13 17:47:12.949037698 +0100
-@@ -159,7 +159,7 @@
+ # Flags to pass to the link stage
+ LDFLAGS = @LDFLAGS@
+ SUDOERS_LDFLAGS = $(LDFLAGS) @SUDOERS_LDFLAGS@
+@@ -163,7 +166,7 @@ Makefile: $(srcdir)/Makefile.in
        (cd $(top_builddir) && ./config.status --file plugins/sudoers/Makefile)
  
  libparsesudoers.la: $(LIBPARSESUDOERS_OBJS)