patch for only using selinux on Linux, prepare to upload debian/1.8.3p2-1
authorBdale Garbee <bdale@gag.com>
Mon, 30 Jan 2012 23:21:16 +0000 (16:21 -0700)
committerBdale Garbee <bdale@gag.com>
Mon, 30 Jan 2012 23:21:16 +0000 (16:21 -0700)
debian/changelog
debian/control
debian/rules

index ca6df5c01477b4834dc214813988ae470f3517dd..5c6a5b8cfff9fcb03e152b1cacd96601759cc7ed 100644 (file)
@@ -1,3 +1,10 @@
+sudo (1.8.3p2-1) unstable; urgency=high
+
+  * new upstream version, closes: #657985 (CVE-2012-0809)
+  * patch from Pino Toscano to only use selinux on Linux, closes: #655894
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 30 Jan 2012 16:11:54 -0700
+
 sudo (1.8.3p1-3) unstable; urgency=low
 
   * patch from Moritz Muehlenhoff enables hardened build flags, closes: #655417
index 352670bcb8d3a8379d2d7e44ee9b94bbffcc9fe6..acfacf926972aef6730ce7cbd2bc161c3623a8ce 100644 (file)
@@ -2,7 +2,7 @@ Source: sudo
 Section: admin
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 7), libpam0g-dev, libldap2-dev, libsasl2-dev, libselinux1-dev, autotools-dev, bison, flex
+Build-Depends: debhelper (>= 7), libpam0g-dev, libldap2-dev, libsasl2-dev, libselinux1-dev [linux-any], autotools-dev, bison, flex
 Standards-Version: 3.9.2
 Vcs-Git: git://git.gag.com/debian/sudo
 Vcs-Browser: http://git.gag.com/?p=debian/sudo
index 725790acc3087b0c3e30ee1e44d741ef4dc6818e..dfa19ed78cdb19120e1e97bc68832b5e34f95627 100755 (executable)
@@ -7,6 +7,11 @@ CFLAGS += -Wall -Wno-comment
 LDFLAGS = `dpkg-buildflags --get LDFLAGS`
 CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
 
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+  configure_args += --with-selinux
+endif
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -19,7 +24,6 @@ configure-stamp:
            CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" $(CURDIR)/configure \
                --prefix=/usr -v \
                --with-all-insults \
-               --with-selinux \
                --with-pam \
                --with-fqdn \
                --with-logging=syslog \
@@ -33,7 +37,8 @@ configure-stamp:
                --with-sendmail=/usr/sbin/sendmail \
                --with-timedir=/var/lib/sudo \
                --mandir=/usr/share/man \
-               --libexecdir=/usr/lib/sudo
+               --libexecdir=/usr/lib/sudo \
+               $(configure_args)
 
        # LDAP version
        mkdir -p build-ldap