Add pforthdic Makefile target
authorPhil Burk <philburk@google.com>
Thu, 17 Nov 2022 19:37:45 +0000 (19:37 +0000)
committerPhil Burk <philburk@mobileer.com>
Sat, 19 Nov 2022 01:29:31 +0000 (01:29 +0000)
This will allow quicker testing without
generating the standalone image.

    make clean pforthdic

platforms/unix/Makefile

index 626d0cefd8eb38e14e9fdf8a13cc4a159fd98355..7b1d74bf92f0822fcb04b4069c306b98ef39f365 100644 (file)
@@ -115,6 +115,8 @@ $(PFORTHAPP): $(PFDICDAT) $(PFEMBOBJS)
 # target aliases
 pfdicapp: $(PFDICAPP)
 
+pforthdic: $(PFORTHDIC)
+
 pfdicdat: $(PFDICDAT)
 
 pforthapp: $(PFORTHAPP)
@@ -123,7 +125,8 @@ help:
        @echo "Use 'make all' to build standalone pForth executable."
        @echo "PForth can be built in several stages using these targets:"
        @echo "   pfdicapp = executable pForth with minimal dictionary. All from 'C'."
-       @echo "   pfdicdat = image of full dictionary build by compiling Forth code."
+       @echo "   pforthdic = executable pforth plus pforth.dic file"
+       @echo "   pfdicdat = header image of full dictionary build by compiling Forth code."
        @echo "   pforthapp = executable with embedded dictionary image. DEFAULT 'all' target."
        @echo ""
        @echo "   The file 'fth/pfdicdat.h' is generated by pForth. It contains a binary image of the Forth dictionary."