clean up diff, add watch file
authorBdale Garbee <bdale@gag.com>
Sun, 15 Feb 2009 17:18:02 +0000 (10:18 -0700)
committerBdale Garbee <bdale@gag.com>
Sun, 15 Feb 2009 17:18:02 +0000 (10:18 -0700)
debian/changelog
debian/rules
debian/watch [new file with mode: 0644]

index 516ff730e8ddc26a19fc411dce75c76a075896c5..db4c6fd7f5d8476fe159a7a61c9499ff3af821e7 100644 (file)
@@ -2,8 +2,12 @@ mtx (1.3.12-1) unstable; urgency=low
 
   * new upstream version, closes: #500590
   * clean up lintian warnings
+  * incorporate two changes suggested by a patch from Adam Cécile (Le_Vert):
+  * add debian/watch
+  * move config.* update to configure target, yields a smaller diff that 
+    doesn't clash with git-buildpackage... already had autotools-dev build dep!
 
- -- Bdale Garbee <bdale@gag.com>  Sun, 15 Feb 2009 09:39:12 -0700
+ -- Bdale Garbee <bdale@gag.com>  Sun, 15 Feb 2009 10:17:54 -0700
 
 mtx (1.3.11-1) unstable; urgency=low
 
index 79c0cb276b40dc43d5637737a4130af4653983cc..4ebd577d42189c3413c1b7b3d37ed78f4b7f7879 100755 (executable)
@@ -7,6 +7,9 @@ export DH_VERBOSE=1
 configure: configure-stamp
 configure-stamp:
        dh_testdir
+       # pick up latest config files provided by autotools-dev
+       cp -f /usr/share/misc/config.sub config.sub
+       cp -f /usr/share/misc/config.guess config.guess
        ./configure --prefix=/usr
        touch configure-stamp
 
@@ -20,14 +23,8 @@ build-stamp: configure-stamp
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp configure-stamp config.guess config.sub
        [ ! -f Makefile ] || $(MAKE) distclean
-
-       -test -r /usr/share/misc/config.sub && \
-               cp -f /usr/share/misc/config.sub config.sub
-       -test -r /usr/share/misc/config.guess && \
-               cp -f /usr/share/misc/config.guess config.guess
-
        dh_clean
 
 install: build
diff --git a/debian/watch b/debian/watch
new file mode 100644 (file)
index 0000000..ab1ee98
--- /dev/null
@@ -0,0 +1,3 @@
+version=3
+opts=dversionmangle=s/~debian$// \
+http://sf.net/mtx/mtx-([0-9\.]+)\.tar\.gz