Imported Upstream version 1.2.17rel upstream/1.2.17rel
authorBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:26:58 +0000 (17:26 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:26:58 +0000 (17:26 -0600)
CHANGES
Makefile.in
mtx.spec
mtx.spec.in
mtxl.c

diff --git a/CHANGES b/CHANGES
index 8c055fd8ded26ba758eba5bff36577ece7f8d417..145ca0c4a9fa4a4d531f8ad19f5429e85cad7a93 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,9 @@
+CHANGES, mtx 1.2.17:
+- copy_barcode was off by one.
+- Replace garbled chars with \0 in case barcodes full of BS. Barcode
+  changes courtesy of dirkx at covalent dot net. Set __WEIRD_CHAR_SUPPRESS
+  to activate this code (it is not activated by default in -current.)
+
 CHANGES, mtx 1.2.16:
 - Fix a very special case that ADIC loaders presented to element status
   parser
index 5eae01e7f535246b80e8194a1ec0a2f6b719646d..8012cbdc8287a12bd3da999ebd701c9933d34825 100644 (file)
@@ -9,7 +9,7 @@
 # GNU Autoconf. 
 
 # Version # for 'make dist'...
-VERSION=1.2.16rel
+VERSION=1.2.17rel
 BINS = mtx tapeinfo loaderinfo scsitape
 
 TARGET = @TARGET@
index e2dbb85174072248217b29097344d8394863388c..7327935df776a64118636c4750656ca5dc2209e8 100644 (file)
--- a/mtx.spec
+++ b/mtx.spec
@@ -1,10 +1,10 @@
 Name: mtx
-Version: 1.2.16rel
+Version: 1.2.17rel
 Release: 1
 Summary: SCSI media changer control program
 Copyright: Redistributable
 Group: Utilities/System
-Source0: http://prdownloads.sourceforge.net/mtx/%{name}-%{version}.tar.gz
+Source0: ftp://ftp.badtux.org/pub/storage/mtx/%{name}-%{version}.tar.gz
 Url: http://%{name}.sourceforge.net
 BuildRoot: /var/tmp/%{name}-%{version}
 
index 2f38e76e44645b506c4d62ff2381bc464d459f7a..4e2c191a58fadd067b245477def061b0283af357 100644 (file)
@@ -4,7 +4,7 @@ Release: 1
 Summary: SCSI media changer control program
 Copyright: Redistributable
 Group: Utilities/System
-Source0: http://prdownloads.sourceforge.net/mtx/%{name}-%{version}.tar.gz
+Source0: ftp://ftp.badtux.org/pub/storage/mtx/%{name}-%{version}.tar.gz
 Url: http://%{name}.sourceforge.net
 BuildRoot: /var/tmp/%{name}-%{version}
 
diff --git a/mtxl.c b/mtxl.c
index 1ad050d632c3f0d487186a5cf86174d4e171b972..c92c3480403e32d60441a7235a7772bd49ecd524 100644 (file)
--- a/mtxl.c
+++ b/mtxl.c
@@ -2,8 +2,8 @@
 
   Copyright 1997-1998 by Leonard N. Zubkoff <lnz@dandelion.com>
 
-$Date: 2002/02/05 16:51:11 $
-$Revision: 1.8.2.3 $
+$Date: 2002/09/27 17:23:28 $
+$Revision: 1.8.2.7 $
 
   This file created Feb 2000 by Eric Lee Green <eric@badtux.org> from pieces
   extracted from mtx.c, plus some additional routines. 
@@ -438,10 +438,15 @@ static ElementStatus_T *AllocateElementData(ElementModeSense_T *mode_sense) {
 void copy_barcode(unsigned char *src, unsigned char *dest) {
   int i;
   
-  for (i=0; i < 37; i++) {
-    *dest++ = *src++;
+  for (i=0; i < 36; i++) {
+    *dest=*src++;
+#ifdef __WEIRD_CHAR_SUPPRESS
+    if ((*dest < 32) || (*dest > 127))
+       *dest = '\0';
+#endif
+     dest++;
   }
-  *dest=0; /* null-terminate, sigh. */ 
+  dest=0; /* null-terminate, sigh. */ 
 }
 
 
@@ -1216,8 +1221,20 @@ void PrintRequestSense(RequestSense_T *RequestSense)
 
 #endif
 
-/* $Date: 2002/02/05 16:51:11 $
+/* $Date: 2002/09/27 17:23:28 $
  * $Log: mtxl.c,v $
+ * Revision 1.8.2.7  2002/09/27 17:23:28  elgreen
+ * Don't dereference pointer in barcode stuff
+ *
+ * Revision 1.8.2.6  2002/09/27 17:20:18  elgreen
+ * doh, get rid of the + from the patch process!
+ *
+ * Revision 1.8.2.5  2002/09/27 17:17:13  elgreen
+ * fix copy_barcode
+ *
+ * Revision 1.8.2.4  2002/09/27 16:49:43  elgreen
+ * copy_barcode was off by one (sigh!)
+ *
  * Revision 1.8.2.3  2002/02/05 16:51:11  elgreen
  * mtx 1.2.16pre3
  *