fix lintian issues
[debian/mtx] / mtx.spec
1 Name: mtx
2 Version: 1.3.12
3 Release: 1%{?dist}
4 Summary: SCSI media changer control program
5 License: GPL
6 Group: Utilities/System
7 Source0: ftp://ftp.opensource-sw.net/pub/mtx/stable/%{name}-%{version}.tar.gz
8 Url: http://%{name}.sourceforge.net
9 BuildRoot: /var/tmp/%{name}-%{version}
10
11
12 %description
13 The MTX program controls the robotic mechanism in autoloaders and tape
14 libraries such as the HP SureStore DAT 40x6, Exabyte EZ-17, and
15 Exabyte 220. This program is also reported to work with a variety of other tape
16 libraries and autochangers from Tandberg/Overland, Breece Hill, HP, and 
17 Seagate.
18
19 %prep
20 %setup -q
21
22 %build
23 %configure
24 make
25
26 %install
27 mkdir -p $RPM_BUILD_ROOT/sbin
28 install mtx $RPM_BUILD_ROOT/sbin/mtx
29 mkdir -p $RPM_BUILD_ROOT/usr/sbin
30 install loaderinfo $RPM_BUILD_ROOT/usr/sbin/loaderinfo
31 install scsieject $RPM_BUILD_ROOT/usr/sbin/scsieject
32 install scsitape $RPM_BUILD_ROOT/usr/sbin/scsitape
33 install tapeinfo $RPM_BUILD_ROOT/usr/sbin/tapeinfo
34 mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
35 install mtx.1 $RPM_BUILD_ROOT/%{_mandir}/man1/mtx.1
36 install loaderinfo.1 $RPM_BUILD_ROOT/%{_mandir}/man1/loaderinfo.1
37 install scsieject.1 $RPM_BUILD_ROOT/%{_mandir}/man1/scsieject.1
38 install scsitape.1 $RPM_BUILD_ROOT/%{_mandir}/man1/scsitape.1
39 install tapeinfo.1 $RPM_BUILD_ROOT/%{_mandir}/man1/tapeinfo.1
40
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files 
46 %defattr(-,root,root)
47 %doc mtx.doc CHANGES README mtxl.README.html
48 %doc COMPATABILITY FAQ LICENSE* TODO contrib
49 %{_mandir}/man1/*
50 /sbin/mtx
51 /usr/sbin/*
52
53 %changelog
54 * Fri Sep 27 2002 Eric Green <eric@badtux.org>
55 - 1.3.0rel
56 - move changelog to end.
57 - change source directory to ftp.badtux.net. 
58 - use * for files to catch new files. 
59
60 * Wed Apr 18 2001 Kenneth Porter <shiva@well.com>
61 - 1.2.12pre1
62 - Need to create usr/sbin for install
63
64 * Fri Mar 02 2001 Eric Green <eric@estinc.com>
65 - 1.2.11pre6 
66 - Move tapeinfo,loaderinfo, scsitape to /usr/sbin rather than /sbin
67
68 * Wed Feb 28 2001 Kenneth Porter <shiva@well.com>
69 - 1.2.11pre5
70 - Remove commented-out patch.
71 - Use mandir FHS macro and configure macro.
72 - Install more stuff.
73 - Use build policy for stripping.
74
75 * Wed Jan 17 2001 Eric Green <eric@estinc.com>
76 - 1.2.11pre3
77 - Removed patch, now use ./configure. 
78
79 * Mon Nov 27 2000 Eric Green <eric@estinc.com>
80 - 1.2.10
81 - Fixed patching to use the portable.patch.
82
83 * Tue Jul 25 2000 Eric Green <eric@estinc.com>
84 - 1.2.8
85 - Added portability patch to mtx.spec so should compile on Red Hat Alpha etc. 
86
87 * Thu Jun 6 2000 Eric Green <eric@estinc.com>
88 - 1.2.7
89 - Fixed single-drive Exabyte 220 special case.
90 - Fixed ADIC DAT Autochanger special case.
91 - Fixed mtx.spec to move the binaries to /sbin since we need root access
92
93 * Fri May 12 2000 Kenneth Porter <shiva@well.com>
94 - 1.2.6
95 - Fixed 'eepos' stuff to use | rather than || (whoops!)
96 - Accept a 4-byte element descriptor for the robot arm for certain older
97 - autochangers. 
98
99 * Mon May 8 2000 Kenneth Porter <shiva@well.com>
100 - Spell sourceforge right so the link at rpmfind.net will work.
101
102 * Thu May 4 2000 Kenneth Porter <shiva@well.com>
103 - 1.2.5
104
105 * Thu Oct 29 1998  Ian Macdonald <ianmacd@xs4all.nl>
106 - moved mtx from /sbin to /bin, seeing as mt is also located there
107
108 * Fri Oct 23 1998  Ian Macdonald <ianmacd@xs4all.nl>
109 - first RPM release