Imported Debian patch 2.3.1-82 debian/2.3.1-82
authorBdale Garbee <bdale@gag.com>
Thu, 6 Jul 2006 15:06:06 +0000 (09:06 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:24:35 +0000 (17:24 -0600)
MAKEDEV
debian/changelog
debian/control
debian/init.d
debian/postinst

diff --git a/MAKEDEV b/MAKEDEV
index f38f0733664a22ae4a44c808703a030133c3657b..479ac9bc71ed2b2e832c04a4ee2904064d350c91 100644 (file)
--- a/MAKEDEV
+++ b/MAKEDEV
@@ -114,7 +114,8 @@ opts="${opt_n:+-n} ${opt_v:+-v} ${opt_d:+-d}"
 #---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#
 
 devicename () {        # translate device names to something safe
-       echo "$*" | sed -e 's/[^A-Za-z0-9_]/_/g'
+       # A-Z is not full alphabet in all locales (e.g. in et_EE)
+       echo "$*" | LC_ALL=C sed -e 's/[^A-Za-z0-9_]/_/g' 
 }
 
 makedev () {   # usage: makedev name [bcu] major minor owner group mode
@@ -256,7 +257,6 @@ cvt () {
                        st)     echo st0 ;;
                        xd)     echo xda xdb ;;
                        ad)     echo ada adb ;;
-                       fd)     echo fd0 fd1 ;;
                        lp)     echo lp ;;
                        mt)     echo ftape ;;
                        qft)    echo ftape ;;
@@ -318,6 +318,8 @@ cvt () {
 
 for arg in `cvt $*`
 do
+       # this is to make the case patterns work as expected in all locales
+       LC_ALL=C
        case $arg in
        generic)
                # pick the right generic-<arch> using dpkg's knowledge
@@ -1617,7 +1619,8 @@ do
                ;;
        md)
                major=`Major md 9` || continue
-               for part in 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
+               for part in 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 \
+                       16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
                do
                        makedev md$part b $major $part $disk
                done
index f5f802cabb2c4f0d800f7f339aac469498034ce0..5903b1cafa45f998821f1f27da7ce2288d93ed5a 100644 (file)
@@ -1,3 +1,14 @@
+makedev (2.3.1-82) unstable; urgency=low
+
+  * create 32 md* devices instead of 16, closes: #367406
+  * Juhan Ernits patch to unify sed behavior across locales, closes: #363017
+  * add LSBInitScripts support to init.d script, closes: #376992
+  * patch from Ubuntu to ensure base tty* set exists in init.d, not just tty0
+  * remove the alias 'fd' as a shorthand for 'fd0 fd1' to allow the real fd
+    target to be reached, closes: #357143
+
+ -- Bdale Garbee <bdale@gag.com>  Thu,  6 Jul 2006 09:06:06 -0600
+
 makedev (2.3.1-81) unstable; urgency=low
 
   * add check for /dev/.udev in init.d at Md's request
index 203f207ee4c601e5d997994e44f9d5f32f5eae3c..c3bbf9bd58e380743c1dd2f9af4f269381ec2f4f 100644 (file)
@@ -2,8 +2,8 @@ Source: makedev
 Section: admin
 Priority: required
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends-Indep: debhelper
-Standards-Version: 3.6.2.1
+Build-Depends: debhelper
+Standards-Version: 3.7.2
 
 Package: makedev
 Architecture: all
index c047f645d36a1670486140a7f541cbf8a61e6e20..c8554edefa6f3ace5c0491899b25f91ff76b8910 100644 (file)
@@ -1,5 +1,14 @@
 #! /bin/sh
 
+### BEGIN INIT INFO
+# Provies:             makedev
+# Required-Start:      $local_fs
+# Required-Stop:       $local_fs
+# Default-Start:       2 3 4 5
+# Default-Stop:                0 1 6
+# Short-Description:   Creates device files in /dev
+### END INIT INFO
+
 N=/etc/init.d/makedev
 PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
 
index 5f46cdddc4f59b5e13b9a57989ee8a86d3b625df..2a255c85052eff0d18378844f53bbf3d588a20f7 100644 (file)
@@ -19,7 +19,11 @@ fi
 
 /bin/chmod g-r,o= /dev/tty[0-9]*
 
-test -e /dev/tty0 || /sbin/MAKEDEV tty0
+# ensure base tty set exists, since debootstrap no longer does
+for i in tty0 tty1 tty2 tty3 tty4 tty5 tty6 tty7 tty8 tty9; do
+       test -e /dev/$i || /sbin/MAKEDEV $i
+done
+
 test -e /dev/random || /sbin/MAKEDEV random
 test -e /dev/urandom || /sbin/MAKEDEV urandom
 test -e /dev/audio || /sbin/MAKEDEV audio