hack
[debian/ipip] / debian / rules
index ebfcde666d1af711b408d7218392d11bcb19b883..12d1bccc4dd598ebdee90b391e541d1276307d19 100755 (executable)
@@ -1,62 +1,8 @@
 #!/usr/bin/make -f
-# rules file for the ipip package, requires debhelper
-# copyright 1998 by Bdale Garbee, distributed under the terms of the GPL
+# rules file for the ipip package, requires debhelper / dh
+# copyright 1998,2012 by Bdale Garbee, GPLv2 or later
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
 
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       $(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       -$(MAKE) clean
-
-       dh_clean
-
-# Build architecture-independent files here.
-binary-indep: build
-
-# Build architecture-dependent files here.
-binary-arch: build
-#      dh_testversion
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       cp ipip debian/tmp/usr/sbin
-       cp debian/ipip.config debian/tmp/etc/ipip/config
-       cp debian/ipip.routes debian/tmp/etc/ipip/routes
-
-       dh_installdocs
-       dh_installexamples samples/*
-       dh_installmenu
-       dh_installinit
-       dh_installcron
-       dh_installmanpages
-#      dh_undocumented
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-#      dh_makeshlibs
-       dh_md5sums
-       dh_builddeb
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+%:
+       dh $@