remove pre-buit Qt moc files, closes: #573759
authorBdale Garbee <bdale@gag.com>
Thu, 22 Apr 2010 08:25:13 +0000 (02:25 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 22 Apr 2010 08:25:13 +0000 (02:25 -0600)
debian/rules

index fd99b3c794a65a2ff21e0e82e6e99c525d1850a2..d6a2ebecaba9119f072b38c58e309d9f25ddbe3a 100755 (executable)
@@ -15,6 +15,11 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp extract-stamp install-stamp
 
+       # Remove (possibly stale) pre-built Qt-generated moc files; they will
+       # be rebuilt using the current Qt moc.  Perhaps this should actually be
+       # part of 'make distclean' and these files not be distributed:
+       rm -f ./gr-qtgui/src/lib/*_moc.cc
+
        if [ -f Makefile ]; \
        then\
                if [ -d .svn ]; \