Merge commit 'upstream/3.2.2'
authorBdale Garbee <bdale@gag.com>
Mon, 10 Aug 2009 18:26:46 +0000 (12:26 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 10 Aug 2009 18:26:46 +0000 (12:26 -0600)
Conflicts:
usrp/doc/Makefile.am
usrp/doc/Makefile.in

1  2 
gnuradio-examples/python/digital/pick_bitrate.py
gnuradio-examples/python/digital/transmit_path.py
gnuradio-examples/python/ofdm/fusb_options.py

index 33a41870562fc954ef44849ca54a6828ac7a085d,9badcdc0840499d081bc0355c99e401cb2c45da2..0567701b10a61bfb2189f58abbaa931332f82c5a
@@@ -1,6 -1,5 +1,6 @@@
 +#!/usr/bin/env python
  #
- # Copyright 2005,2006 Free Software Foundation, Inc.
+ # Copyright 2005, 2006, 2007 Free Software Foundation, Inc.
  # 
  # This file is part of GNU Radio
  # 
index 0000000000000000000000000000000000000000,153e06bea76b0c175a0aba1950b123218303419f..d537a2feb21907d328fac62211d9b9e5efd416cd
mode 000000,100644..100644
--- /dev/null
@@@ -1,0 -1,31 +1,32 @@@
++#!/usr/bin/env python
+ #
+ # Copyright 2006 Free Software Foundation, Inc.
+ # 
+ # This file is part of GNU Radio
+ # 
+ # GNU Radio is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+ # the Free Software Foundation; either version 3, or (at your option)
+ # any later version.
+ # 
+ # GNU Radio is distributed in the hope that it will be useful,
+ # but WITHOUT ANY WARRANTY; without even the implied warranty of
+ # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ # GNU General Public License for more details.
+ # 
+ # You should have received a copy of the GNU General Public License
+ # along with GNU Radio; see the file COPYING.  If not, write to
+ # the Free Software Foundation, Inc., 51 Franklin Street,
+ # Boston, MA 02110-1301, USA.
+ # 
+ def add_options(parser):
+     """
+     Add Fast USB specifc options to command line parser.
+     
+     @param parser: instance of OptionParser
+     """
+     parser.add_option("-B", "--fusb-block-size", type="int", default=0,
+                       help="specify fast usb block size [default=%default]")
+     parser.add_option("-N", "--fusb-nblocks", type="int", default=0,
+                       help="specify number of fast usb blocks [default=%default]")