howto: cleanup for merge
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Fri, 13 Nov 2009 19:27:55 +0000 (11:27 -0800)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Fri, 13 Nov 2009 19:27:55 +0000 (11:27 -0800)
gr-howto-write-a-block/README.hacking
gr-howto-write-a-block/python/__init__.py
gr-howto-write-a-block/swig/Makefile.am

index a9e68dd890e4646c10706a1d98e772fd4bc382c3..c670fd19e1cdf0dc53772c7d0aca04bf66a8e3b2 100644 (file)
@@ -69,16 +69,16 @@ that exports the C++ API into a Python namespace.  Each GNU Radio block gets a
 .i file (using SWIG syntax).  The master howto.i file must also have a line
 to include the block header file and a line to import the block .i file. The
 resulting _howto_swig.so and _howto_swig.py files are installed into the
-system Python lib directory under howto/ and become part of the gnuradio.howto
-Python namespace.  The Makefile.am must be customized to recognize new files
-created here.
+system Python lib directory under gnuradio/howto and become part of the
+gnuradio.howto Python namespace.  The Makefile.am must be customized to
+recognize new files created here.
 
 The 'python' directory contains pure Python modules that get installed into
-the system Python lib directory under howto/ and the __init__.py module
-needed to turn the directory into the gnuradio.howto namespace.  This is the
-appropriate place to put hierarchical blocks and utility classes.  Be sure
-to edit the __init__.py to add your module/symbol imports as necessary, and
-to modify the Makefile.am accordingly.
+the system Python lib directory under gnuradio/howto and the __init__.py
+module needed to turn the directory into the gnuradio.howto namespace.
+This is the appropriate place to put hierarchical blocks and utility classes.
+Be sure to edit the __init__.py to add your module/symbol imports as
+necessary, and to modify the Makefile.am accordingly.
 
 This directory also contains Python-based QA code, which is executed during
 'make check'.
index 3107e1fb9822c7b65cae1e06757234d0779eb202..d4a41c271b7c2faa85782be72e3c4bee5b4845c8 100644 (file)
@@ -36,7 +36,7 @@ if _RTLD_GLOBAL != 0:
 # ----------------------------------------------------------------
 
 
-# import swig generated symbols into the trppm namespace
+# import swig generated symbols into the howto namespace
 from howto_swig import *
 
 # import any pure python here
index 8c94f50411fb3a7abd785335e3dc869b62cf8d81..fc40109d0568e3cc061bdc334e8e7ed28fbd2423 100644 (file)
@@ -34,8 +34,7 @@ TOP_SWIG_IFILES =             \
 #   import gnuradio.howto
 # This ends up at:
 #   ${prefix}/lib/python${python_version}/site-packages/gnuradio
-howto_pythondir_category =     \
-       gnuradio
+howto_pythondir_category = gnuradio/howto
 
 howto_la_swig_libadd =         \
        $(top_builddir)/lib/libgnuradio-howto.la