updated copyright info, and snuck a little something else in (you didn't see anything...)
authortrondeau <trondeau@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 26 Jan 2007 20:02:22 +0000 (20:02 +0000)
committertrondeau <trondeau@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 26 Jan 2007 20:02:22 +0000 (20:02 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4294 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-core/src/lib/io/Makefile.am
gnuradio-core/src/lib/io/gr_udp_sink.cc
gnuradio-core/src/lib/io/gr_udp_sink.h
gnuradio-core/src/lib/io/gr_udp_sink.i
gnuradio-core/src/lib/io/gr_udp_source.cc
gnuradio-core/src/lib/io/gr_udp_source.h
gnuradio-core/src/lib/io/gr_udp_source.i
gnuradio-core/src/python/gnuradio/blksimpl/nbfm_tx.py

index 6891f3807a488afbed7619b63a79d354fa94a55b..8320375c7f6cd1674af7246bb7bec55e0b9e5a02 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2001,2003,2004 Free Software Foundation, Inc.
+# Copyright 2001,2003,2004,2006 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -79,7 +79,9 @@ grinclude_HEADERS =                   \
        microtune_xxxx_eval_board.h     \
        ppio.h                          \
        ppio_ppdev.h                    \
-       sdr_1000.h                      
+       sdr_1000.h                      \
+       gr_udp_sink.h                   \
+       gr_udp_source.h
 
 
 swiginclude_HEADERS =                  \
index f5eefdc73fd261a220e392ce30f594f269585954..a664615f19da8e14f2c6c83302269c60a7bd5f11 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004 Free Software Foundation, Inc.
+ * Copyright 2006 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
index f3ededa52419c7fb398d2a04e438810c8f7bcb58..ee346f40c604a1dec30efa2fcaeebb363200c68d 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004 Free Software Foundation, Inc.
+ * Copyright 2006 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
index 59c828dd6e99fc5e3085fff84640b2c69c7cfe35..bd4accb3eda13c3f12bb47fd0e45c411da9049b4 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004 Free Software Foundation, Inc.
+ * Copyright 2006 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
index 426830924ce3ef55aae05684cb7b379a842698c2..70b2f8f988db8e9ed2c6339629da9d7afce255b3 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004,2006 Free Software Foundation, Inc.
+ * Copyright 2006 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
index 162eef7d640e2b9a2a6293b2327d49398132e139..c57f4fc8fc1f64314b6702884dcf6b5ac4aa3717 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004 Free Software Foundation, Inc.
+ * Copyright 2006 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
index e1e9c20236b987ebc4cefc5b0afffee70b07c55b..1d6f4c9048365464d3c782baa805755e22e2c553 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004 Free Software Foundation, Inc.
+ * Copyright 2006 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
index 15c7bbbb451f2cc793ba1c935afcfa4a567c35d9..47dc4d46a294bde21c32afc12ace69f20fe20dd3 100644 (file)
@@ -58,13 +58,16 @@ class nbfm_tx(gr.hier_block):
         
         if do_interp:
             interp_factor = quad_rate / audio_rate
-            interp_taps = optfir.low_pass (interp_factor,   # gain
-                                           quad_rate,       # Fs
-                                           4500,            # passband cutoff
-                                           7000,            # stopband cutoff
-                                           0.1,            # passband ripple dB
-                                           40)              # stopband atten dB
+            if 0:
+                interp_taps = optfir.low_pass (interp_factor,   # gain
+                                               quad_rate,       # Fs
+                                               4500,            # passband cutoff
+                                               7000,            # stopband cutoff
+                                               0.1,        # passband ripple dB
+                                               40)              # stopband atten dB
 
+            else:
+                interp_taps = gr.firdes.low_pass(interp_factor, quad_rate, 10e3, 8e3)
             #print "len(interp_taps) =", len(interp_taps)
             self.interpolator = gr.interp_fir_filter_fff (interp_factor, interp_taps)