Merge branch 'master' into wip/burx_support
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Wed, 12 May 2010 01:00:19 +0000 (18:00 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Wed, 12 May 2010 01:00:19 +0000 (18:00 -0700)
* master: (39 commits)
  Add gru.hexshort to deal with short hex constants
  Assign USB PID for Hans de Bok
  Add missing buffer allocator hint to gr_ofdm_sampler.cc
  Really fix the missing include for boost::bind
  gr-wxgui: Added additional color table entries
  Missed updates for omnithread/mblock removal
  Remove omnithreads library.
  Remove mblock library.  We hardly knew 'ye.
  Convert gr-audio-portaudio to Boost via gruel
  Further updates for removing omnithreads
  Update build configuration for OSX omnithreads changeover
  Add missing include file for boost::bind
  Convert gcell to use boost::threads instead of omnithread.
  Fix sequence error indication after stopping then restarting streaming on USRP2.
  initial move from mld_threads to gruel:: namespace threads and such
  Initial changes to remove mld_thread and instead use gruel:: namespace classes
  Fixing doxygen warnings from arb_resampler. Also, removed set_taps from public
  Fixing doxygen warnings from channelizer block.
  Fixing documentation to get rid of doxygen warnings.
  Adding documentation for fff version of othe PFB clock sync algorithm.
  ...

1  2 
usrp/host/lib/Makefile.am

index 1fff1548bf509e6ab63933fdfeef29c4b01c5336,5848412c936e9ee9e82212a62b06e6dc37410592..f01ff8a0adbac064b16d5c0abaea6dd44390abb6
@@@ -1,7 -1,7 +1,7 @@@
  #
  #  USRP - Universal Software Radio Peripheral
  #
- #  Copyright (C) 2003,2004,2006,2007,2008,2009 Free Software Foundation, Inc.
+ #  Copyright (C) 2003,2004,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
  #
  #  This program is free software; you can redistribute it and/or modify
  #  it under the terms of the GNU General Public License as published by
@@@ -31,10 -31,10 +31,10 @@@ libusrp_la_common_LIBADD =                 
        $(BOOST_THREAD_LIB)             \
        ../misc/libmisc.la
  
- # darwin fusb requires omnithreads
+ # darwin fusb requires gruel (for threading)
  if FUSB_TECH_darwin
- AM_CPPFLAGS = $(common_INCLUDES) $(OMNITHREAD_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
- libusrp_la_LIBADD = $(libusrp_la_common_LIBADD) $(OMNITHREAD_LA)
+ AM_CPPFLAGS = $(common_INCLUDES) $(GRUEL_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
+ libusrp_la_LIBADD = $(libusrp_la_common_LIBADD) $(GRUEL_LA)
  libusrp_la_LDFLAGS = $(libusrp_la_common_LDFLAGS) -framework CoreFoundation
  else
  AM_CPPFLAGS = $(common_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
@@@ -70,7 -70,6 +70,6 @@@ darwin_CODE =                         
        circular_buffer.h               \
        circular_linked_list.h          \
        darwin_libusb.h                 \
-       mld_threads.h                   \
        usrp_prims_libusb0.cc           
  
  
@@@ -121,7 -120,6 +120,7 @@@ libusrp_la_common_SOURCES =                
        db_boards.cc                    \
        db_base.cc                      \
        db_basic.cc                     \
 +      db_bitshark_rx.cc               \
        db_tv_rx.cc                     \
        db_tv_rx_mimo.cc                \
        db_flexrf.cc                    \