Merge branch 'wip/pager' of git@gnuradio.org:jcorgan
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Sat, 12 Dec 2009 17:34:35 +0000 (09:34 -0800)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Sat, 12 Dec 2009 17:34:35 +0000 (09:34 -0800)
Merge-fix: Fix erroneous EXTRA_DIST in lib/
Merge-fix: Don't install usrp_rx_flex.py (unfinished)

1  2 
gr-pager/apps/Makefile.am
gr-pager/lib/Makefile.am

index 0000000000000000000000000000000000000000,0e9f1215bfed07ab464208a5dedf78b288800108..7b495fd2b46202be188c4ae3350f0e47c8fe1189
mode 000000,100644..100644
--- /dev/null
@@@ -1,0 -1,35 +1,36 @@@
 -      usrp_flex_band.py \
+ #
+ # Copyright 2009 Free Software Foundation, Inc.
+ # 
+ # This file is part of GNU Radio
+ # 
+ # GNU Radio is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+ # the Free Software Foundation; either version 3, or (at your option)
+ # any later version.
+ # 
+ # GNU Radio is distributed in the hope that it will be useful,
+ # but WITHOUT ANY WARRANTY; without even the implied warranty of
+ # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ # GNU General Public License for more details.
+ # 
+ # You should have received a copy of the GNU General Public License
+ # along with GNU Radio; see the file COPYING.  If not, write to
+ # the Free Software Foundation, Inc., 51 Franklin Street,
+ # Boston, MA 02110-1301, USA.
+ # 
+ include $(top_srcdir)/Makefile.common
+ if PYTHON
+ dist_bin_SCRIPTS = \
+       usrp_flex.py \
+       usrp_flex_all.py \
 -
++      usrp_flex_band.py
++
++noinst_PYTHON = \
+       usrp_rx_flex.py
+ endif
+ EXTRA_DIST = \
+       usrp_rx_flex.grc
index 0000000000000000000000000000000000000000,42053eb17ca1e4bd79adc69d800cc79c07060e60..1d8a43b3c831fd4073469cd7ac309fe1da09ee04
mode 000000,100644..100644
--- /dev/null
@@@ -1,0 -1,55 +1,53 @@@
 -EXTRA_DIST = run_tests.in
 -
+ #
+ # Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+ # 
+ # This file is part of GNU Radio
+ # 
+ # GNU Radio is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+ # the Free Software Foundation; either version 3, or (at your option)
+ # any later version.
+ # 
+ # GNU Radio is distributed in the hope that it will be useful,
+ # but WITHOUT ANY WARRANTY; without even the implied warranty of
+ # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ # GNU General Public License for more details.
+ # 
+ # You should have received a copy of the GNU General Public License
+ # along with GNU Radio; see the file COPYING.  If not, write to
+ # the Free Software Foundation, Inc., 51 Franklin Street,
+ # Boston, MA 02110-1301, USA.
+ # 
+ include $(top_srcdir)/Makefile.common
+ AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
+ # These headers get installed in ${prefix}/include/gnuradio
+ grinclude_HEADERS = \
+       pager_slicer_fb.h \
+       pager_flex_sync.h \
+       pager_flex_deinterleave.h \
+       pager_flex_parse.h \
+       pager_flex_frame.h \
+       pageri_bch3221.h \
+       pageri_flex_modes.h \
+       pageri_util.h
+ lib_LTLIBRARIES = libgnuradio-pager.la
+ libgnuradio_pager_la_SOURCES = \
+       pager_flex_frame.cc \
+       pager_slicer_fb.cc \
+       pager_flex_sync.cc \
+       pager_flex_deinterleave.cc \
+       pager_flex_parse.cc \
+       pageri_bch3221.cc \
+       pageri_flex_modes.cc \
+       pageri_util.cc
+ libgnuradio_pager_la_LIBADD = \
+       $(GNURADIO_CORE_LA)
+ libgnuradio_pager_la_LDFLAGS =        \
+       $(NO_UNDEFINED)