Fixes gr-qtgui make distcheck failure when QT is not installed.
authorTom Rondeau <trondeau@vt.edu>
Sun, 13 Jun 2010 18:31:11 +0000 (14:31 -0400)
committerTom Rondeau <trondeau@vt.edu>
Sun, 13 Jun 2010 18:31:11 +0000 (14:31 -0400)
gr-qtgui/src/lib/Makefile.am

index 26b97d1d45f0f27426c6ed3bb74e6ec2ccff0a04..5377bf07280b7e3010bfff927e38f40ec1498f97 100644 (file)
@@ -54,7 +54,6 @@ libgnuradio_qtgui_la_SOURCES =        \
        SpectrumGUIClass.cc                     \
        spectrumUpdateEvents.cc                 \
        plot_waterfall.cc                       \
-       $(QMAKE_SOURCES)                        \
        qtgui_sink_c.cc                         \
        qtgui_sink_f.cc
 
@@ -75,6 +74,8 @@ grinclude_HEADERS =                   \
        qtgui_sink_c.h                  \
        qtgui_sink_f.h
 
+nodist_libqtsrc_la_SOURCES = $(QMAKE_SOURCES)
+
 %_moc.cc : %.h
        $(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -p $(srcdir) $< -o $@