grc: rename execution binary from 'grc' to 'gnuradio-companion'
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Tue, 18 May 2010 20:53:39 +0000 (13:53 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Tue, 18 May 2010 20:53:39 +0000 (13:53 -0700)
This change resolves a conflict with the Generic Colorizer application
which also uses the binary name 'grc'.

Interested users can add an alias to their shell environment to run
gnuradio-companion when grc is invoked.

grc/freedesktop/Makefile.am
grc/freedesktop/gnuradio-gnuradio-companion.desktop [new file with mode: 0644]
grc/freedesktop/gnuradio-grc.desktop [deleted file]
grc/freedesktop/grc_setup_freedesktop.in
grc/scripts/Makefile.am
grc/scripts/gnuradio-companion [new file with mode: 0755]
grc/scripts/grc [deleted file]

index bfbdee9404fea4671740d578050cec6132bc2706..23bb70bf54db8ef94a816e1b41e78cfdec70c40a 100644 (file)
@@ -30,7 +30,7 @@ dist_ourdata_DATA = \
        grc-icon-48.png \
        grc-icon-32.png \
        gnuradio-grc.xml \
-       gnuradio-grc.desktop \
+       gnuradio-gnuradio-companion.desktop \
        gnuradio-usrp2_probe.desktop \
        gnuradio-usrp_probe.desktop
 
diff --git a/grc/freedesktop/gnuradio-gnuradio-companion.desktop b/grc/freedesktop/gnuradio-gnuradio-companion.desktop
new file mode 100644 (file)
index 0000000..5fd0497
--- /dev/null
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=GRC
+Exec=gnuradio-companion %F
+Categories=Development;
+MimeType=application/gnuradio-grc;
+Icon=gnuradio-grc
diff --git a/grc/freedesktop/gnuradio-grc.desktop b/grc/freedesktop/gnuradio-grc.desktop
deleted file mode 100644 (file)
index d9c70ca..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=GRC
-Exec=grc %F
-Categories=Development;
-MimeType=application/gnuradio-grc;
-Icon=gnuradio-grc
index db65064524577a859218760b26e3d5b9efbda6a6..a0c5ac193bde67f06bf58ae60d6ea4564202d86f 100644 (file)
@@ -8,7 +8,7 @@
 ##################################################
 
 ICON_SIZES="32 48 64 128 256"
-MENU_ITEMS="grc usrp2_probe usrp_probe"
+MENU_ITEMS="gnuradio-companion usrp2_probe usrp_probe"
 if [ -n "$2" ]; then
        SRCDIR="$2"
 else
index e24f88800f0ddc68b65d7245ceed2efab379ec8d..9019ec5cc9611256ee220318a7cfe60ddb05b917 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008, 2009 Free Software Foundation, Inc.
+# Copyright 2008, 2009, 2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -21,4 +21,4 @@
 
 include $(top_srcdir)/Makefile.common
 
-dist_bin_SCRIPTS = grc usrp2_probe usrp_probe
+dist_bin_SCRIPTS = gnuradio-companion usrp2_probe usrp_probe
diff --git a/grc/scripts/gnuradio-companion b/grc/scripts/gnuradio-companion
new file mode 100755 (executable)
index 0000000..a4115c3
--- /dev/null
@@ -0,0 +1,54 @@
+#!/usr/bin/env python
+"""
+Copyright 2009 Free Software Foundation, Inc.
+This file is part of GNU Radio
+
+GNU Radio Companion is free software; you can redistribute it and/or
+modify it under the terms of the GNU General Public License
+as published by the Free Software Foundation; either version 2
+of the License, or (at your option) any later version.
+
+GNU Radio Companion is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program; if not, write to the Free Software
+Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA
+"""
+
+import pygtk
+pygtk.require('2.0')
+import gtk
+
+try: from gnuradio import gr
+except ImportError, e:
+       d = gtk.MessageDialog(type=gtk.MESSAGE_ERROR, buttons=gtk.BUTTONS_CLOSE, message_format="""
+Cannot import gnuradio. Are your PYTHONPATH and LD_LIBRARY_PATH set correctly?""")
+       d.set_title(str(e))
+       d.run()
+       exit(-1)
+
+from gnuradio import gr
+from optparse import OptionParser
+
+if __name__ == "__main__":
+       usage = 'usage: %prog [options] [saved flow graphs]'
+       version = """
+GNU Radio Companion %s
+
+This program is part of GNU Radio
+GRC comes with ABSOLUTELY NO WARRANTY.
+This is free software,
+and you are welcome to redistribute it.
+"""%gr.version()
+       parser = OptionParser(usage=usage, version=version)
+       (options, args) = parser.parse_args()
+       from gnuradio.grc.python.Platform import Platform
+       from gnuradio.grc.gui.ActionHandler import ActionHandler
+       #setup icon using icon theme
+       try: gtk.window_set_default_icon(gtk.IconTheme().load_icon('gnuradio-grc', 256, 0))
+       except: pass
+       ActionHandler(args, Platform())
+
diff --git a/grc/scripts/grc b/grc/scripts/grc
deleted file mode 100755 (executable)
index a4115c3..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/usr/bin/env python
-"""
-Copyright 2009 Free Software Foundation, Inc.
-This file is part of GNU Radio
-
-GNU Radio Companion is free software; you can redistribute it and/or
-modify it under the terms of the GNU General Public License
-as published by the Free Software Foundation; either version 2
-of the License, or (at your option) any later version.
-
-GNU Radio Companion is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program; if not, write to the Free Software
-Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA
-"""
-
-import pygtk
-pygtk.require('2.0')
-import gtk
-
-try: from gnuradio import gr
-except ImportError, e:
-       d = gtk.MessageDialog(type=gtk.MESSAGE_ERROR, buttons=gtk.BUTTONS_CLOSE, message_format="""
-Cannot import gnuradio. Are your PYTHONPATH and LD_LIBRARY_PATH set correctly?""")
-       d.set_title(str(e))
-       d.run()
-       exit(-1)
-
-from gnuradio import gr
-from optparse import OptionParser
-
-if __name__ == "__main__":
-       usage = 'usage: %prog [options] [saved flow graphs]'
-       version = """
-GNU Radio Companion %s
-
-This program is part of GNU Radio
-GRC comes with ABSOLUTELY NO WARRANTY.
-This is free software,
-and you are welcome to redistribute it.
-"""%gr.version()
-       parser = OptionParser(usage=usage, version=version)
-       (options, args) = parser.parse_args()
-       from gnuradio.grc.python.Platform import Platform
-       from gnuradio.grc.gui.ActionHandler import ActionHandler
-       #setup icon using icon theme
-       try: gtk.window_set_default_icon(gtk.IconTheme().load_icon('gnuradio-grc', 256, 0))
-       except: pass
-       ActionHandler(args, Platform())
-