Merged r4750:4755 from jcorgan/frac into trunk. Adds gr_fractional_interpolator_ff...
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 14 Mar 2007 22:49:45 +0000 (22:49 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 14 Mar 2007 22:49:45 +0000 (22:49 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4756 221aa14e-8319-0410-a670-987f0aec2ac5

12 files changed:
gnuradio-core/src/lib/filter/Makefile.am
gnuradio-core/src/lib/filter/filter.i
gnuradio-core/src/lib/filter/gr_fractional_interpolator.cc [deleted file]
gnuradio-core/src/lib/filter/gr_fractional_interpolator.h [deleted file]
gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.cc [new file with mode: 0644]
gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.h [new file with mode: 0644]
gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.i [new file with mode: 0644]
gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.cc [new file with mode: 0644]
gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.h [new file with mode: 0644]
gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.i [new file with mode: 0644]
gnuradio-core/src/python/gnuradio/gr/Makefile.am
gnuradio-core/src/python/gnuradio/gr/qa_fractional_interpolator.py [new file with mode: 0755]

index 32be27044a93567fa7f771496e6c2a152995b320..b22f37c12a1e08aeae862b589a80c88aa2821415 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2001,2002,2004,2005,2006 Free Software Foundation, Inc.
+# Copyright 2001,2002,2004,2005,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -170,7 +170,8 @@ libfilter_la_common_SOURCES =               \
        gr_fft_filter_fff.cc            \
        gr_goertzel_fc.cc               \
        gr_filter_delay_fc.cc           \
-       gr_fractional_interpolator.cc   \
+       gr_fractional_interpolator_ff.cc \
+       gr_fractional_interpolator_cc.cc \
        gr_hilbert_fc.cc                \
        gr_iir_filter_ffd.cc            \
        gr_sincos.c                     \
@@ -229,7 +230,8 @@ grinclude_HEADERS =                         \
        gr_fft_filter_fff.h             \
        gr_filter_delay_fc.h            \
        gr_fir_sysconfig_x86.h          \
-       gr_fractional_interpolator.h    \
+       gr_fractional_interpolator_ff.h \
+       gr_fractional_interpolator_cc.h \
        gr_goertzel_fc.h                \
        gr_hilbert_fc.h                 \
        gr_iir_filter_ffd.h             \
@@ -291,6 +293,8 @@ swiginclude_HEADERS =                       \
        gr_fft_filter_ccc.i             \
        gr_fft_filter_fff.i             \
        gr_filter_delay_fc.i            \
+       gr_fractional_interpolator_ff.i \
+       gr_fractional_interpolator_cc.i \
        gr_goertzel_fc.i                \
        gr_hilbert_fc.i                 \
        gr_iir_filter_ffd.i             \
index 6d16ae872904327683b9f86253b7759231ac0071..c7a06b455db45f48d742a7f280c75e6a513e27b8 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004,2005,2006 Free Software Foundation, Inc.
+ * Copyright 2004,2005,2006,2007 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
@@ -28,6 +28,8 @@
 #include <gr_filter_delay_fc.h>
 #include <gr_fft_filter_ccc.h>
 #include <gr_fft_filter_fff.h>
+#include <gr_fractional_interpolator_ff.h>
+#include <gr_fractional_interpolator_cc.h>
 #include <gr_goertzel_fc.h>
 #include <gr_cma_equalizer_cc.h>
 %}
@@ -39,6 +41,8 @@
 %include "gr_filter_delay_fc.i"
 %include "gr_fft_filter_ccc.i"
 %include "gr_fft_filter_fff.i"
+%include "gr_fractional_interpolator_ff.i"
+%include "gr_fractional_interpolator_cc.i"
 %include "gr_goertzel_fc.i"
 %include "gr_cma_equalizer_cc.i"
 
diff --git a/gnuradio-core/src/lib/filter/gr_fractional_interpolator.cc b/gnuradio-core/src/lib/filter/gr_fractional_interpolator.cc
deleted file mode 100644 (file)
index cee337c..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2004 Free Software Foundation, Inc.
- *
- * This file is part of GNU Radio
- *
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2, or (at your option)
- * any later version.
- *
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-#ifdef HAVE_CONFIG_H
-#include "config.h"
-#endif
-
-#include <gr_io_signature.h>
-#include <gr_fractional_interpolator.h>
-#include <gri_mmse_fir_interpolator.h>
-#include <stdexcept>
-
-// Public constructor
-gr_fractional_interpolator_sptr gr_make_fractional_interpolator(float phase_shift, float interp_ratio)
-{
-  return gr_fractional_interpolator_sptr(new gr_fractional_interpolator(phase_shift, interp_ratio));
-}
-
-gr_fractional_interpolator::gr_fractional_interpolator(float phase_shift, float interp_ratio)
-  : gr_block ("fractional_interpolator",
-             gr_make_io_signature (1, 1, sizeof (float)),
-             gr_make_io_signature (1, 1, sizeof (float))),
-    d_mu (phase_shift), d_mu_inc (interp_ratio), d_interp()
-{
-  if (interp_ratio <=  0)
-    throw std::out_of_range ("interpolation ratio must be > 0");
-  if (phase_shift <  0  || phase_shift > 1)
-    throw std::out_of_range ("phase shift ratio must be > 0 and < 1");
-
-  set_relative_rate (1.0 / interp_ratio);
-}
-
-gr_fractional_interpolator::~gr_fractional_interpolator()
-{
-    delete d_interp;
-}
-
-void
-gr_fractional_interpolator::forecast(int noutput_items, gr_vector_int &ninput_items_required)
-{
-  unsigned ninputs = ninput_items_required.size();
-  for (unsigned i=0; i < ninputs; i++)
-
-    ninput_items_required[i] =
-      (int) ceil((noutput_items * d_mu_inc) + d_interp->ntaps());
-}
-
-int
-gr_fractional_interpolator::general_work(int noutput_items,
-                                        gr_vector_int &ninput_items,
-                                        gr_vector_const_void_star &input_items,
-                                        gr_vector_void_star &output_items)
-{
-  const float *in = (const float *) input_items[0];
-  float *out = (float *) output_items[0];
-
-  int  ii = 0;                         // input index
-  int          oo = 0;                         // output index
-
-  while (oo < noutput_items){
-
-    // produce output sample
-
-    out[oo++] = d_interp->interpolate(&in[ii], d_mu);
-
-    //  printf( "%4d %9.6f\n", ii, d_mu);
-
-    double s = d_mu + d_mu_inc;
-    double f = floor (s);
-    int incr = (int) f;
-    d_mu = s - f;
-    ii += incr;
-  }
-
-  consume_each (ii);
-
-  return noutput_items;
-}
diff --git a/gnuradio-core/src/lib/filter/gr_fractional_interpolator.h b/gnuradio-core/src/lib/filter/gr_fractional_interpolator.h
deleted file mode 100644 (file)
index 108694e..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2004 Free Software Foundation, Inc.
- *
- * This file is part of GNU Radio
- *
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2, or (at your option)
- * any later version.
- *
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-#ifndef INCLUDED_GR_FRACTIONAL_INTERPOLATOR_H
-#define        INCLUDED_GR_FRACTIONAL_INTERPOLATOR_H
-
-#include <gr_block.h>
-
-class gri_mmse_fir_interpolator;
-
-class gr_fractional_interpolator;
-typedef boost::shared_ptr<gr_fractional_interpolator> gr_fractional_interpolator_sptr;
-
-// public constructor
-gr_fractional_interpolator_sptr gr_make_fractional_interpolator (float phase_shift, float interp_ratio);
-
-/*!
- * \brief Interpolating mmse filter with float input, float output
- * \ingroup filter
- */
-class gr_fractional_interpolator : public gr_block
-{
- public:
-  ~gr_fractional_interpolator ();
-  void forecast(int noutput_items, gr_vector_int &ninput_items_required);
-  int general_work (int noutput_items,
-                   gr_vector_int &ninput_items,
-                   gr_vector_const_void_star &input_items,
-                   gr_vector_void_star &output_items);
-
-protected:
-  gr_fractional_interpolator (float phase_shift, float interp_ratio);
-
- private:
-  float                        d_mu;
-  float                        d_mu_inc;
-  gri_mmse_fir_interpolator    *d_interp;
-
-  friend gr_fractional_interpolator_sptr
-    gr_make_fractional_interpolator (float phase_shift, float interp_ratio);
-};
-
-#endif
diff --git a/gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.cc b/gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.cc
new file mode 100644 (file)
index 0000000..312626a
--- /dev/null
@@ -0,0 +1,93 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2004,2007 Free Software Foundation, Inc.
+ *
+ * This file is part of GNU Radio
+ *
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ *
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
+
+#include <gr_io_signature.h>
+#include <gr_fractional_interpolator_cc.h>
+#include <gri_mmse_fir_interpolator_cc.h>
+#include <stdexcept>
+
+// Public constructor
+gr_fractional_interpolator_cc_sptr gr_make_fractional_interpolator_cc(float phase_shift, float interp_ratio)
+{
+  return gr_fractional_interpolator_cc_sptr(new gr_fractional_interpolator_cc(phase_shift, interp_ratio));
+}
+
+gr_fractional_interpolator_cc::gr_fractional_interpolator_cc(float phase_shift, float interp_ratio)
+  : gr_block ("fractional_interpolator_cc",
+             gr_make_io_signature (1, 1, sizeof (float)),
+             gr_make_io_signature (1, 1, sizeof (float))),
+    d_mu (phase_shift), d_mu_inc (interp_ratio), d_interp(new gri_mmse_fir_interpolator_cc())
+{
+  if (interp_ratio <=  0)
+    throw std::out_of_range ("interpolation ratio must be > 0");
+  if (phase_shift <  0  || phase_shift > 1)
+    throw std::out_of_range ("phase shift ratio must be > 0 and < 1");
+
+  set_relative_rate (1.0 / interp_ratio);
+}
+
+gr_fractional_interpolator_cc::~gr_fractional_interpolator_cc()
+{
+  delete d_interp;
+}
+
+void
+gr_fractional_interpolator_cc::forecast(int noutput_items, gr_vector_int &ninput_items_required)
+{
+  unsigned ninputs = ninput_items_required.size();
+  for (unsigned i=0; i < ninputs; i++)
+
+    ninput_items_required[i] =
+      (int) ceil((noutput_items * d_mu_inc) + d_interp->ntaps());
+}
+
+int
+gr_fractional_interpolator_cc::general_work(int noutput_items,
+                                           gr_vector_int &ninput_items,
+                                           gr_vector_const_void_star &input_items,
+                                           gr_vector_void_star &output_items)
+{
+  const gr_complex *in = (const gr_complex *) input_items[0];
+  gr_complex *out = (gr_complex *) output_items[0];
+
+  int  ii = 0;                         // input index
+  int          oo = 0;                         // output index
+
+  while (oo < noutput_items) {
+
+    out[oo++] = d_interp->interpolate(&in[ii], d_mu);
+
+    double s = d_mu + d_mu_inc;
+    double f = floor (s);
+    int incr = (int) f;
+    d_mu = s - f;
+    ii += incr;
+  }
+
+  consume_each (ii);
+
+  return noutput_items;
+}
diff --git a/gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.h b/gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.h
new file mode 100644 (file)
index 0000000..a178661
--- /dev/null
@@ -0,0 +1,67 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2004,2007 Free Software Foundation, Inc.
+ *
+ * This file is part of GNU Radio
+ *
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ *
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#ifndef INCLUDED_GR_FRACTIONAL_INTERPOLATOR_CC_H
+#define        INCLUDED_GR_FRACTIONAL_INTERPOLATOR_CC_H
+
+#include <gr_block.h>
+
+class gri_mmse_fir_interpolator_cc;
+
+class gr_fractional_interpolator_cc;
+typedef boost::shared_ptr<gr_fractional_interpolator_cc> gr_fractional_interpolator_cc_sptr;
+
+// public constructor
+gr_fractional_interpolator_cc_sptr gr_make_fractional_interpolator_cc (float phase_shift, float interp_ratio);
+
+/*!
+ * \brief Interpolating mmse filter with gr_complex input, gr_complex output
+ * \ingroup filter
+ */
+class gr_fractional_interpolator_cc : public gr_block
+{
+public:
+  ~gr_fractional_interpolator_cc ();
+  void forecast(int noutput_items, gr_vector_int &ninput_items_required);
+  int general_work (int noutput_items,
+                   gr_vector_int &ninput_items,
+                   gr_vector_const_void_star &input_items,
+                   gr_vector_void_star &output_items);
+
+  float mu() const { return d_mu;}
+  float interp_ratio() const { return d_mu_inc;}
+  void set_mu (float mu) { d_mu = mu; }
+  void set_interp_ratio (float interp_ratio) { d_mu_inc = interp_ratio; }
+
+protected:
+  gr_fractional_interpolator_cc (float phase_shift, float interp_ratio);
+
+private:
+  float                        d_mu;
+  float                        d_mu_inc;
+  gri_mmse_fir_interpolator_cc         *d_interp;
+
+  friend gr_fractional_interpolator_cc_sptr
+  gr_make_fractional_interpolator_cc (float phase_shift, float interp_ratio);
+};
+
+#endif
diff --git a/gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.i b/gnuradio-core/src/lib/filter/gr_fractional_interpolator_cc.i
new file mode 100644 (file)
index 0000000..fd51ec7
--- /dev/null
@@ -0,0 +1,37 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2007 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+GR_SWIG_BLOCK_MAGIC(gr,fractional_interpolator_cc);
+
+gr_fractional_interpolator_cc_sptr gr_make_fractional_interpolator_cc (float phase_shift, float interp_ratio);
+
+class gr_fractional_interpolator_cc : public gr_block
+{
+private:
+  gr_fractional_interpolator_cc (float phase_shift, float interp_ratio);
+
+public:
+  float mu() const;
+  float interp_ratio() const;
+  void set_mu (float mu);
+  void set_interp_ratio (float interp_ratio);
+};
diff --git a/gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.cc b/gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.cc
new file mode 100644 (file)
index 0000000..3254b1f
--- /dev/null
@@ -0,0 +1,93 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2004,2007 Free Software Foundation, Inc.
+ *
+ * This file is part of GNU Radio
+ *
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ *
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
+
+#include <gr_io_signature.h>
+#include <gr_fractional_interpolator_ff.h>
+#include <gri_mmse_fir_interpolator.h>
+#include <stdexcept>
+
+// Public constructor
+gr_fractional_interpolator_ff_sptr gr_make_fractional_interpolator_ff(float phase_shift, float interp_ratio)
+{
+  return gr_fractional_interpolator_ff_sptr(new gr_fractional_interpolator_ff(phase_shift, interp_ratio));
+}
+
+gr_fractional_interpolator_ff::gr_fractional_interpolator_ff(float phase_shift, float interp_ratio)
+  : gr_block ("fractional_interpolator_ff",
+             gr_make_io_signature (1, 1, sizeof (float)),
+             gr_make_io_signature (1, 1, sizeof (float))),
+    d_mu (phase_shift), d_mu_inc (interp_ratio), d_interp(new gri_mmse_fir_interpolator())
+{
+  if (interp_ratio <=  0)
+    throw std::out_of_range ("interpolation ratio must be > 0");
+  if (phase_shift <  0  || phase_shift > 1)
+    throw std::out_of_range ("phase shift ratio must be > 0 and < 1");
+
+  set_relative_rate (1.0 / interp_ratio);
+}
+
+gr_fractional_interpolator_ff::~gr_fractional_interpolator_ff()
+{
+  delete d_interp;
+}
+
+void
+gr_fractional_interpolator_ff::forecast(int noutput_items, gr_vector_int &ninput_items_required)
+{
+  unsigned ninputs = ninput_items_required.size();
+  for (unsigned i=0; i < ninputs; i++)
+
+    ninput_items_required[i] =
+      (int) ceil((noutput_items * d_mu_inc) + d_interp->ntaps());
+}
+
+int
+gr_fractional_interpolator_ff::general_work(int noutput_items,
+                                           gr_vector_int &ninput_items,
+                                           gr_vector_const_void_star &input_items,
+                                           gr_vector_void_star &output_items)
+{
+  const float *in = (const float *) input_items[0];
+  float *out = (float *) output_items[0];
+
+  int  ii = 0;                         // input index
+  int          oo = 0;                         // output index
+
+  while (oo < noutput_items) {
+
+    out[oo++] = d_interp->interpolate(&in[ii], d_mu);
+
+    double s = d_mu + d_mu_inc;
+    double f = floor (s);
+    int incr = (int) f;
+    d_mu = s - f;
+    ii += incr;
+  }
+
+  consume_each (ii);
+
+  return noutput_items;
+}
diff --git a/gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.h b/gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.h
new file mode 100644 (file)
index 0000000..7f144cd
--- /dev/null
@@ -0,0 +1,67 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2004,2007 Free Software Foundation, Inc.
+ *
+ * This file is part of GNU Radio
+ *
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ *
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#ifndef INCLUDED_GR_FRACTIONAL_INTERPOLATOR_FF_H
+#define        INCLUDED_GR_FRACTIONAL_INTERPOLATOR_FF_H
+
+#include <gr_block.h>
+
+class gri_mmse_fir_interpolator;
+
+class gr_fractional_interpolator_ff;
+typedef boost::shared_ptr<gr_fractional_interpolator_ff> gr_fractional_interpolator_ff_sptr;
+
+// public constructor
+gr_fractional_interpolator_ff_sptr gr_make_fractional_interpolator_ff (float phase_shift, float interp_ratio);
+
+/*!
+ * \brief Interpolating mmse filter with float input, float output
+ * \ingroup filter
+ */
+class gr_fractional_interpolator_ff : public gr_block
+{
+public:
+  ~gr_fractional_interpolator_ff ();
+  void forecast(int noutput_items, gr_vector_int &ninput_items_required);
+  int general_work (int noutput_items,
+                   gr_vector_int &ninput_items,
+                   gr_vector_const_void_star &input_items,
+                   gr_vector_void_star &output_items);
+
+  float mu() const { return d_mu;}
+  float interp_ratio() const { return d_mu_inc;}
+  void set_mu (float mu) { d_mu = mu; }
+  void set_interp_ratio (float interp_ratio) { d_mu_inc = interp_ratio; }
+
+protected:
+  gr_fractional_interpolator_ff (float phase_shift, float interp_ratio);
+
+private:
+  float                        d_mu;
+  float                        d_mu_inc;
+  gri_mmse_fir_interpolator    *d_interp;
+
+  friend gr_fractional_interpolator_ff_sptr
+  gr_make_fractional_interpolator_ff (float phase_shift, float interp_ratio);
+};
+
+#endif
diff --git a/gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.i b/gnuradio-core/src/lib/filter/gr_fractional_interpolator_ff.i
new file mode 100644 (file)
index 0000000..6f26b05
--- /dev/null
@@ -0,0 +1,37 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2007 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+GR_SWIG_BLOCK_MAGIC(gr,fractional_interpolator_ff);
+
+gr_fractional_interpolator_ff_sptr gr_make_fractional_interpolator_ff (float phase_shift, float interp_ratio);
+
+class gr_fractional_interpolator_ff : public gr_block
+{
+private:
+  gr_fractional_interpolator_ff (float phase_shift, float interp_ratio);
+
+public:
+  float mu() const;
+  float interp_ratio() const;
+  void set_mu (float mu);
+  void set_interp_ratio (float interp_ratio);
+};
index 339fb81dd0e3df4454eb3533af8ac67e585db160..3969a28fd117476f7c8131c91840764af4df1633 100644 (file)
@@ -60,6 +60,7 @@ noinst_PYTHON =                       \
        qa_fft_filter.py                \
        qa_filter_delay_fc.py           \
        qa_flow_graph.py                \
+       qa_fractional_interpolator.py   \
        qa_frequency_modulator.py       \
        qa_fsk_stuff.py                 \
        qa_goertzel.py                  \
diff --git a/gnuradio-core/src/python/gnuradio/gr/qa_fractional_interpolator.py b/gnuradio-core/src/python/gnuradio/gr/qa_fractional_interpolator.py
new file mode 100755 (executable)
index 0000000..afeebb5
--- /dev/null
@@ -0,0 +1,39 @@
+#!/usr/bin/env python
+#
+# Copyright 2007 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+from gnuradio import gr, gr_unittest
+
+class test_fractional_resampler (gr_unittest.TestCase):
+
+    def setUp(self):
+        self.fg = gr.flow_graph()
+
+    def tearDown(self):
+        self.fg = None
+
+    def test_000_make(self):
+        op = gr.fractional_interpolator_ff(0.0, 1.0)
+        op2 = gr.fractional_interpolator_cc(0.0, 1.0)
+        
+if __name__ == '__main__':
+    gr_unittest.main()
+