Removed preprocessor declrs out of fusb.h and created separate fusb_libusb1_base.h
authorttsou <ttsou@vt.edu>
Mon, 14 Sep 2009 23:50:26 +0000 (19:50 -0400)
committerttsou <ttsou@vt.edu>
Wed, 16 Sep 2009 21:08:52 +0000 (17:08 -0400)
13 files changed:
usrp/host/lib/Makefile.am
usrp/host/lib/fusb.cc
usrp/host/lib/fusb.h
usrp/host/lib/fusb_libusb1.cc
usrp/host/lib/fusb_libusb1.h
usrp/host/lib/fusb_libusb1_base.h [new file with mode: 0644]
usrp/host/lib/fusb_linux.cc
usrp/host/lib/fusb_sysconfig_libusb1.cc
usrp/host/lib/fusb_win32.cc
usrp/host/lib/usrp_basic_common.cc
usrp/host/lib/usrp_basic_libusb0.cc
usrp/host/lib/usrp_basic_libusb1.cc
usrp/host/lib/usrp_prims_common.cc

index 7455b153696896fb2bb01ecaf140a0cc8b8404b7..3687aae72c8797555463e4399df374891b40bccc 100644 (file)
@@ -61,7 +61,9 @@ BUILT_SOURCES += usrp_dbid.cc \
 
 generic_CODE =                                 \
        fusb_generic.cc                 \
-       fusb_sysconfig_generic.cc
+       fusb_sysconfig_generic.cc       \
+       usrp_prims_libusb0.cc           \
+       usrp_basic_libusb0.cc
 
 darwin_CODE =                          \
        fusb_darwin.cc                  \
@@ -87,7 +89,9 @@ linux_CODE =                          \
 
 ra_wb_CODE =                           \
        fusb_ra_wb.cc                   \
-       fusb_sysconfig_ra_wb.cc
+       fusb_sysconfig_ra_wb.cc         \
+       usrp_prims_libusb0.cc           \
+       usrp_basic_libusb0.cc
 
 libusb1_CODE =                         \
        fusb_libusb1.cc                 \
@@ -162,6 +166,7 @@ noinst_HEADERS =                    \
        db_boards.h                     \
        db_util.h                       \
        fusb.h                          \
+       fusb_libusb1_base.h             \
        fusb_darwin.h                   \
        fusb_generic.h                  \
        fusb_linux.h                    \
index 0bd9ded59e6d0397801fcf3e2bcc865c2340e7fb..992e1a2e96049472fd7b7425c790b7df3dfa863f 100644 (file)
  * Boston, MA 02110-1301, USA.
  */
 
-//#ifdef HAVE_CONFIG_H
-//#include "config.h"
-//#endif
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
 
+#ifdef HAVE_LIBUSB_1 
+#include <fusb_libusb1_base.h>
+#else
 #include <fusb.h>
-
+#endif
 
 // ------------------------------------------------------------------------
 //                          device handle
index 2ff7dc89fa529eacdbb8b47c47f2754a48bd0bc5..506f396fa3c3fbce25c0674a8ee6c36733e349f9 100644 (file)
 #ifndef _FUSB_H_
 #define _FUSB_H_
 
-/*
- * This is bad, but it works for now. The fusb header files are not installed.
- */
-
-#ifdef HAVE_CONFIG_H
-#include "config.h"
-#endif
-
-#ifdef HAVE_LIBUSB_1 
-struct  libusb_device_handle;
-#else
 struct usb_dev_handle;
 typedef usb_dev_handle libusb_device_handle;
-#endif
 
 struct         libusb_context;
 class   fusb_ephandle;
index 1be2fa2f1e4dca32c777b677d7655e425eebd92f..6ea7607268d0f5d69397bd0f31d9acbdfc593680 100644 (file)
@@ -20,9 +20,9 @@
  * Boston, MA 02110-1301, USA.
  */
 
-//#ifdef HAVE_CONFIG_H
-//#include "config.h"
-//#endif
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
 
 #include <fusb_libusb1.h>
 #include <libusb-1.0/libusb.h>
index 4bc49aafbda8db3ef416f5768628044b71c93330..0257ac38a5d46c45ae3f7358bed4519d991bee1f 100644 (file)
@@ -23,7 +23,7 @@
 #ifndef _FUSB_LIBUSB1_H_
 #define _FUSB_LIBUSB1_H_
 
-#include <fusb.h>
+#include <fusb_libusb1_base.h>
 #include <list>
 
 struct libusb_transfer;
diff --git a/usrp/host/lib/fusb_libusb1_base.h b/usrp/host/lib/fusb_libusb1_base.h
new file mode 100644 (file)
index 0000000..6a24364
--- /dev/null
@@ -0,0 +1,140 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2003 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+// Fast USB interface
+
+#ifndef _FUSB_LIBUSB1_BASE_H_
+#define _FUSB_LIBUSB1_BASE_H_
+
+struct  libusb_device_handle;
+struct         libusb_context;
+class   fusb_ephandle;
+
+/*!
+ * \brief abstract usb device handle
+ */
+class fusb_devhandle {
+private:
+  // NOT IMPLEMENTED
+  fusb_devhandle (const fusb_devhandle &rhs);            // no copy constructor
+  fusb_devhandle &operator= (const fusb_devhandle &rhs);  // no assignment operator
+
+protected:
+  libusb_device_handle         *d_udh;
+
+public:
+  // CREATORS
+  fusb_devhandle (libusb_device_handle *udh);
+  virtual ~fusb_devhandle ();
+
+  // MANIPULATORS
+  
+  /*!
+   * \brief return an ephandle of the correct subtype
+   */
+  virtual fusb_ephandle *make_ephandle (int endpoint, bool input_p,
+                                       int block_size = 0, int nblocks = 0) = 0;
+  
+  // ACCESSORS
+  libusb_device_handle *get_usb_dev_handle () const { return d_udh; }
+};
+
+
+/*!
+ * \brief abstract usb end point handle
+ */
+class fusb_ephandle {
+private:
+  // NOT IMPLEMENTED
+  fusb_ephandle (const fusb_ephandle &rhs);            // no copy constructor
+  fusb_ephandle &operator= (const fusb_ephandle &rhs);  // no assignment operator
+
+protected:
+  int                          d_endpoint;
+  bool                         d_input_p;
+  int                          d_block_size;
+  int                          d_nblocks;
+  bool                         d_started;
+
+public:
+  fusb_ephandle (int endpoint, bool input_p,
+                int block_size = 0, int nblocks = 0);
+  virtual ~fusb_ephandle ();
+
+  virtual bool start () = 0;   //!< begin streaming i/o
+  virtual bool stop () = 0;    //!< stop streaming i/o
+
+  /*!
+   * \returns \p nbytes if write was successfully enqueued, else -1.
+   * Will block if no free buffers available.
+   */
+  virtual int write (const void *buffer, int nbytes) = 0;
+
+  /*!
+   * \returns number of bytes read or -1 if error.
+   * number of bytes read will be <= nbytes.
+   * Will block if no input available.
+   */
+  virtual int read (void *buffer, int nbytes) = 0;
+
+  /*
+   * block until all outstanding writes have completed
+   */
+  virtual void wait_for_completion () = 0;
+
+  /*!
+   * \brief returns current block size.
+   */
+  int block_size () { return d_block_size; };
+};
+
+
+/*!
+ * \brief factory for creating concrete instances of the appropriate subtype.
+ */
+class fusb_sysconfig {
+public:
+  /*!
+   * \brief returns fusb_devhandle or throws if trouble
+   */
+  static fusb_devhandle *make_devhandle (libusb_device_handle *udh,
+                                         libusb_context *ctx = 0);
+
+  /*!
+   * \brief Returns max block size in bytes (hard limit).
+   */
+  static int max_block_size ();
+
+  /*!
+   * \brief Returns default block size in bytes.
+   */
+  static int default_block_size ();
+
+  /*!
+   * \brief Returns the default buffer size in bytes.
+   */
+  static int default_buffer_size ();
+
+};
+
+#endif /*_FUSB_LIBUSB1_BASE_H_ */
+
index 0b3aaed71454c6ad78f68394943c34634b679bf7..6c484569f36562b148d7d35396705e9e32eb53b7 100644 (file)
@@ -20,9 +20,9 @@
  * Boston, MA 02110-1301, USA.
  */
 
-//#ifdef HAVE_CONFIG_H
-//#include "config.h"
-//#endif
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
 
 #include <fusb_linux.h>
 #include <usb.h>               // libusb header
index f71e34fa947dcc14c326954e5eaeee918f70c944..ab3c475d59d89dca0407d857a2034b65c4b5f15c 100644 (file)
@@ -20,7 +20,7 @@
  * Boston, MA 02110-1301, USA.
  */
 
-#include <fusb.h>
+#include <fusb_libusb1_base.h>
 #include <fusb_libusb1.h>
 
 static const int MAX_BLOCK_SIZE = 16 * 1024;           // hard limit
index 7b11bb9198f2ab2ee2be92ef5d8976ae1da48bd9..8900576d93b7d4a8b1777992f4c8f1bac40e13fa 100644 (file)
@@ -20,9 +20,9 @@
  * Boston, MA 02110-1301, USA.
  */
 
-//#ifdef HAVE_CONFIG_H
-//#include "config.h"
-//#endif
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
 
 #include <fusb_win32.h>
 #include <usb.h>
index ad1eca56d254e300e6de05677d93e84d058548af..9a1f9fd550cfef534af39c2916d7aa22d7f72e5b 100644 (file)
  * Boston, MA 02110-1301, USA.
  */
 
-//#ifdef HAVE_CONFIG_H
-//#include "config.h"
-//#endif
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
+
+#ifdef HAVE_LIBUSB_1
+#include "fusb_libusb1_base.h"
+#include <libusb-1.0/libusb.h>
+#else
+#include "fusb.h"
+#include <usb.h>
+#endif
 
 #include "usrp/usrp_basic.h"
 #include "usrp/usrp_prims.h"
 #include "usrp_interfaces.h"
 #include "fpga_regs_common.h"
 #include "fpga_regs_standard.h"
-#include "fusb.h"
 #include "db_boards.h"
 #include <stdexcept>
 #include <assert.h>
 #include <string.h>
 #include <cstdio>
 
-#ifdef HAVE_LIBUSB_1
-#include <libusb-1.0/libusb.h>
-#else
-#include <usb.h>
-#endif
-
 using namespace ad9862;
 
 #define NELEM(x) (sizeof (x) / sizeof (x[0]))
index bd22d6ad4f12bafded7a3b5efa888b8b786c33e8..6e41585bb3b492e0c404eddadf26aba20a340305 100644 (file)
@@ -20,9 +20,9 @@
  * Boston, MA 02110-1301, USA.
  */
 
-//#ifdef HAVE_CONFIG_H
-//#include "config.h"
-//#endif
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
 
 #include <usrp/usrp_basic.h>
 #include "usrp/usrp_prims.h"
index 64cff6078649765cd9ec93ada4fbf60b1d263ce5..7cfd69be6717f5e13f77f8c38511159649068e4b 100644 (file)
@@ -29,7 +29,7 @@
 #include "usrp_interfaces.h"
 #include "fpga_regs_common.h"
 #include "fpga_regs_standard.h"
-#include "fusb.h"
+#include "fusb_libusb1_base.h"
 #include "db_boards.h"
 #include <libusb-1.0/libusb.h>
 #include <stdexcept>
index c9fcf80df5b4d0f26e452b2c8b3ed36099b98233..41722b23bea7c1f67232ef55d2247b4784dca422 100644 (file)
 #include "config.h"
 #endif
 
+#ifdef HAVE_LIBUSB_1 
+#include <libusb-1.0/libusb.h>
+#else
+#include <usb.h>
+#endif
+
 #include "usrp/usrp_prims.h"
 #include "usrp_commands.h"
 #include "usrp_ids.h"
 #include <assert.h>
 #include "std_paths.h"
 
-#ifdef HAVE_LIBUSB_1 
-#include <libusb-1.0/libusb.h>
-#else
-#include <usb.h>
-#endif
-
 extern "C" {
 #include "md5.h"
 };