Imported Debian patch 3.0.4-1 debian/3.0.4-1
authorBdale Garbee <bdale@gag.com>
Wed, 15 Aug 2007 04:38:32 +0000 (22:38 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 10 Aug 2009 18:09:59 +0000 (12:09 -0600)
config.guess
config.sub
debian/changelog
debian/copyright
gnuradio-core/src/lib/runtime/gr_dispatcher.cc

index 02ef1910ab527ca0cd7895ede548b13693c30ff9..0f0fe712ae6d6e0cfa6d50da3b1812ef530de814 100755 (executable)
@@ -4,11 +4,11 @@
 #   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 #   Inc.
 
-timestamp='2007-07-22'
+timestamp='2007-03-06'
 
 # This file is free software; you can redistribute it and/or modify it
 # under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or
+# the Free Software Foundation; either version 2 of the License, or
 # (at your option) any later version.
 #
 # This program is distributed in the hope that it will be useful, but
@@ -330,7 +330,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
     sun4*:SunOS:5.*:* | tadpole*:SunOS:5.*:*)
        echo sparc-sun-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
        exit ;;
-    i86pc:SunOS:5.*:* | i86xen:SunOS:5.*:*)
+    i86pc:SunOS:5.*:*)
        echo i386-pc-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
        exit ;;
     sun4*:SunOS:6*:*)
@@ -793,7 +793,7 @@ EOF
        exit ;;
     *:Interix*:[3456]*)
        case ${UNAME_MACHINE} in
-           x86)
+           x86) 
                echo i586-pc-interix${UNAME_RELEASE}
                exit ;;
            EM64T | authenticamd)
index 97a7b086e96e5279abe13c272ab8811ecad0643d..5defff65a6e4cd091921d9bcab0ab286092ec39e 100755 (executable)
@@ -4,7 +4,7 @@
 #   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 #   Inc.
 
-timestamp='2007-06-28'
+timestamp='2007-01-18'
 
 # This file is (in principle) common to ALL GNU software.
 # The presence of a machine in this file suggests that SOME GNU software
@@ -12,7 +12,7 @@ timestamp='2007-06-28'
 #
 # This file is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or
+# the Free Software Foundation; either version 2 of the License, or
 # (at your option) any later version.
 #
 # This program is distributed in the hope that it will be useful,
@@ -475,8 +475,8 @@ case $basic_machine in
                basic_machine=craynv-cray
                os=-unicosmp
                ;;
-       cr16)
-               basic_machine=cr16-unknown
+       cr16c)
+               basic_machine=cr16c-unknown
                os=-elf
                ;;
        crds | unos)
@@ -683,10 +683,6 @@ case $basic_machine in
                basic_machine=i386-pc
                os=-mingw32
                ;;
-       mingw32ce)
-               basic_machine=arm-unknown
-               os=-mingw32ce
-               ;;
        miniframe)
                basic_machine=m68000-convergent
                ;;
index ca781ab7f59c667b7bdf4ddaf16f9a3a906b07a2..783d47109191626ab5fe7652e0aa2e01c125ef24 100644 (file)
@@ -1,3 +1,10 @@
+gnuradio (3.0.4-1) unstable; urgency=low
+
+  * new upstream version
+  * fix build failure with gcc-4.3 by adding a #include, closes: #420896
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 14 Aug 2007 22:38:32 -0600
+
 gnuradio (3.0.3-1) unstable; urgency=low
 
   * new upstream version
index e5ec004330710ba93f1edf5bb4f4dbc7e3ddfe01..677c88274658ee08eaae73122d8bfa773eb51c33 100644 (file)
@@ -20,7 +20,3 @@ under the GNU General Public License (GPL), a copy of which is available
 on a Debian system at:
 
   /usr/share/common-licenses/GPL
-
-The Debian packaging is (C) 2006, Bdale Garbee <bdale@gag.com> and
-is also licensed under the GPL.
-
index 1b0a1d7a302fd25d92a3dd0316915cacb84da7b3..e165361fc2ca2851f736376625aee3522c528489 100644 (file)
@@ -27,6 +27,7 @@
 #include <gr_dispatcher.h>
 #include <math.h>
 #include <errno.h>
+#include <stdio.h>
 
 #ifdef HAVE_SELECT
 #  ifdef HAVE_SYS_SELECT_H