Imported Debian patch 3.0-2 debian/3.0-2
authorBdale Garbee <bdale@gag.com>
Fri, 10 Nov 2006 08:39:38 +0000 (00:39 -0800)
committerBdale Garbee <bdale@gag.com>
Mon, 10 Aug 2009 18:09:41 +0000 (12:09 -0600)
config.sub
debian/changelog
debian/control

index 387c18d1a135c2e33cb9f911c198efdf7b12b96c..fab0aa3556632a4aec253b77804270a096c11c3e 100755 (executable)
@@ -4,7 +4,7 @@
 #   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 #   Inc.
 
-timestamp='2006-07-02'
+timestamp='2006-09-20'
 
 # This file is (in principle) common to ALL GNU software.
 # The presence of a machine in this file suggests that SOME GNU software
@@ -276,6 +276,7 @@ case $basic_machine in
        | pdp10 | pdp11 | pj | pjl \
        | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
        | pyramid \
+       | score \
        | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
        | sh64 | sh64le \
        | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
@@ -284,7 +285,7 @@ case $basic_machine in
        | tahoe | thumb | tic4x | tic80 | tron \
        | v850 | v850e \
        | we32k \
-       | x86 | xscale | xscalee[bl] | xstormy16 | xtensa \
+       | x86 | xc16x | xscale | xscalee[bl] | xstormy16 | xtensa \
        | z8k)
                basic_machine=$basic_machine-unknown
                ;;
@@ -367,7 +368,7 @@ case $basic_machine in
        | tron-* \
        | v850-* | v850e-* | vax-* \
        | we32k-* \
-       | x86-* | x86_64-* | xps100-* | xscale-* | xscalee[bl]-* \
+       | x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
        | xstormy16-* | xtensa-* \
        | ymp-* \
        | z8k-*)
@@ -909,6 +910,10 @@ case $basic_machine in
        sb1el)
                basic_machine=mipsisa64sb1el-unknown
                ;;
+       sde)
+               basic_machine=mipsisa32-sde
+               os=-elf
+               ;;
        sei)
                basic_machine=mips-sei
                os=-seiux
@@ -1366,6 +1371,9 @@ else
 # system, and we'll never get to this point.
 
 case $basic_machine in
+        score-*)
+               os=-elf
+               ;;
         spu-*)
                os=-elf
                ;;
index 769deb8309db6f6fdea4b11d6a93e37ea383c595..b69baf353c4a12f49c5fc92227b68ea8345ef197 100644 (file)
@@ -1,3 +1,17 @@
+gnuradio (3.0-2) unstable; urgency=high
+
+  * reworked package dependencies so that the 'gnuradio' binary package no
+    longer depends on the pieces in contrib.  instead, the 'usrp' binary
+    package in contrib now depends on all the USRP-related pieces.  A user
+    who doesn't have a USRP board can just install 'gnuradio' and get all
+    the relevant pieces, a USRP user needs to install both 'gnuradio' and
+    'usrp'.  Closes: #394533
+  * improve consistency of references to 'GNU Radio' as upstream project name
+  * make the gnuradio package dependencies on python-gnuradio and python-usrp
+    be version specific on suggestion from Ramakrishnan Muthukrishnan
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 10 Nov 2006 00:39:38 -0800
+
 gnuradio (3.0-1) unstable; urgency=low
 
   * new maintainer, new upstream version
index 96bc8a0958c8bde4b64d503b579c9dbdaec208e2..09fc46e7666d01a36d7b2288457c1e2e087607e7 100644 (file)
@@ -3,20 +3,26 @@ Section: comm
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Conflicts: automake1.8, automake1.9
-Build-Depends: debhelper (>= 5.0.37.2), autotools-dev, doxygen, fftw3-dev, libasound2-dev, libboost-dev, libcppunit-dev, libjack0.100.0-dev, libsdl1.2-dev, portaudio19-dev, libtool, libusb-dev, pkg-config, python, python-all-dev, python-central (>= 0.5), python-numeric, python-wxgtk2.6, sdcc, swig
+Build-Depends: debhelper (>= 5.0.37.2), autotools-dev, doxygen, fftw3-dev, libasound2-dev, libboost-dev, libcppunit-dev, libjack0.100.0-dev, libsdl1.2-dev, portaudio19-dev, libtool, libusb-dev, pkg-config, python, python-central (>= 0.5), python-numeric, python-wxgtk2.6, sdcc, swig
 Build-Depends-Indep: python-all-dev
 Standards-Version: 3.7.2
 XS-Python-Version: >= 2.3
 
 Package: gnuradio
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, python, gnuradio-doc, libgnuradio-core0-dev, libgnuradio-core0c2a, libgnuradio-core0c2a-dbg, usrp, usrp-firmware, libusrp0-dev, libusrp0c2a, libusrp0c2a-dbg, python-gnuradio, python-usrp, gnuradio-examples
+Section: comm
+Depends: ${shlibs:Depends}, ${misc:Depends}, python, gnuradio-doc, libgnuradio-core0-dev, libgnuradio-core0c2a, libgnuradio-core0c2a-dbg, python-gnuradio (= ${Source-Version}), gnuradio-examples
+Suggests: usrp
 Conflicts: gr-audio-alsa, gr-audio-oss, gr-audio-jack, gr-wxgui
 Replaces: gr-audio-alsa, gr-audio-oss, gr-audio-jack, gr-wxgui
 XB-Python-Version: ${python:Versions}
 Description: Software Defined Radio
  This is a meta-package that depends on the various components of a complete
  installation of the GNU Radio softare defined radio system.
+ .
+ If you have a USRP, you probably also want to install the usrp package as
+ suggested, which lives in contrib because the FPGA bitstrings require 
+ non-free tools to build.
 
 Package: gnuradio-doc
 Section: doc
@@ -60,8 +66,8 @@ Description: Software Defined Radio
 Package: usrp
 Section: contrib/comm
 Architecture: any
-Depends: ${shlibs:Depends}, python
-Recommends: hotplug, usrp-firmware
+Depends: ${shlibs:Depends}, python, libusrp0-dev, libusrp0c2a-dbg, python-usrp (= ${Source-Version})
+Recommends: gnuradio, hotplug, usrp-firmware
 XB-Python-Version: ${python:Versions}
 Description: control applications and firmware for the USRP
  The Universal Software Radio Peripheral (USRP) is an USB-connected,
@@ -69,15 +75,15 @@ Description: control applications and firmware for the USRP
  and digital-to-analog converters, an FPGA and a microcontroller. It's
  ideal for capturing or transmitting various signals, usually in
  combination with GNU Radio. The design schemas are available under a
- free license.
+ free license.  Visit ettus.com for more information on the USRP.
  .
  This package contains a tool for loading firmware and doing other
  simple administrative tasks for the USRP (usrper), as well as the
- actual firmware binaries for the microcontroller.
+ actual firmware binaries for the microcontroller.  
  .
- Note that this package does _not_ contain the FPGA bitstrings, which
- you will probably also want to get something useful out of the USRP.
For that, see the package "usrp-firmware" in contrib.
+ This package also depends on all of the other USRP-related packages 
+ so that installing this package will pull in all the pieces you might 
want or need to successfully use the USRP with GNU Radio.
 
 Package: usrp-firmware
 Section: contrib/comm
@@ -149,7 +155,7 @@ Depends: ${python:Depends}, libgnuradio-core0c2a, python-numeric
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
-Description: Python bindings for GNURadio
+Description: Python bindings for GNU Radio
  This provides the module that enable one to use gnuradio from Python
  scripts.  You will need Python and gnuradio-dev installed to use this.
 
@@ -175,7 +181,7 @@ Package: gnuradio-examples
 Architecture: all
 Depends: ${python:Depends}, libgnuradio-core0c2a, python-gnuradio
 XB-Python-Version: ${python:Versions}
-Description: Example programs to test and use GNURadio
+Description: Example programs to test and use GNU Radio
  This package contains Python programs which uses and tests
  the GNU Radio libraries. The examples include dialtone generation,
  complete FM receiver and many more exciting applications.