updated top-level .gitignore
authorEric Blossom <eb@comsec.com>
Sun, 13 Sep 2009 19:30:29 +0000 (12:30 -0700)
committerEric Blossom <eb@comsec.com>
Sun, 13 Sep 2009 19:30:29 +0000 (12:30 -0700)
.gitignore

index b11bb113a1b66c8762a0312c7eb8c436b7fc2e7e..b333709ee11bbe673fcfbfc4fd94f0ee99cce818 100644 (file)
@@ -1,3 +1,30 @@
+#
+# NOTE! Don't add files that are generated in specific
+# subdirectories here. Add them in the ".gitignore" file
+# in that subdirectory instead.
+#
+# NOTE! Please use 'git ls-files -i --exclude-standard'
+# command after changing this file, to see if there are
+# any tracked files which get ignored after the change.
+#
+.*
+*.o
+*.a
+*.ko
+*.so
+*.la
+*.lo
+*.py[oc]
+*.gz
+*.patch
+*~
+\#*#
+.deps
+.libs
+TAGS
+*-stamp
+!.gitignore
+make.log
 /configure
 /Makefile.in
 /config.log
@@ -17,4 +44,3 @@
 /compile
 /build
 /run_tests.sh
-/*-stamp