gnuradio-core: Disable (temporarily) interpolator tap calculation
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Fri, 14 May 2010 02:10:44 +0000 (19:10 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Fri, 14 May 2010 02:10:44 +0000 (19:10 -0700)
There is some breakage with GR_FORTRAN / AC_PROG_F77 when running
bootstrap.  The gen_interpolator_taps binary is only needed to
regenerate the MMSE interpolator taps, which hasn't been done for
several years.  Disable this until proper fix can be done.

configure.ac
gnuradio-core/src/gen_interpolator_taps/Makefile.am

index a170933858129292469d33c743192dabc54b2248..6d70e03decdd6cf15aa304089b9bb281a114c837 100644 (file)
@@ -124,7 +124,7 @@ dnl AC_DISABLE_SHARED       dnl don't build shared libraries
 AC_ENABLE_SHARED       dnl do build shared libraries
 AC_DISABLE_STATIC      dnl don't build static libraries
 m4_ifdef([LT_INIT],[LT_INIT],[AC_PROG_LIBTOOL])
-GR_FORTRAN
+dnl GR_FORTRAN
 
 GR_NO_UNDEFINED                dnl do we need the -no-undefined linker flag
 GR_SCRIPTING
index 5f3a6cb25401e7380b244ebdbbf3615c3a63ed4b..f5d21631b008b3679870c7dd126d6d0e0d9c619c 100644 (file)
 
 include $(top_srcdir)/Makefile.common
 
-EXTRA_DIST                     = praxis.txt simpson.h
+EXTRA_DIST                     = praxis.txt simpson.h objective_fct.c gen_interpolator_taps.c simpson.c praxis.f
 
-if ENABLE_FORTRAN
-noinst_PROGRAMS                        = gen_interpolator_taps
-noinst_HEADERS                 = simpson.h
-
-gen_interpolator_taps_SOURCES  = gen_interpolator_taps.c objective_fct.c simpson.c praxis.f
-gen_interpolator_taps_LDADD    = $(FLIBS) -lm
-
-endif
+dnl if ENABLE_FORTRAN
+dnl noinst_PROGRAMS                    = gen_interpolator_taps
+dnl noinst_HEADERS                     = simpson.h
+dnl 
+dnl gen_interpolator_taps_SOURCES      = gen_interpolator_taps.c objective_fct.c simpson.c praxis.f
+dnl gen_interpolator_taps_LDADD        = $(FLIBS) -lm
+dnl
+dnl endif