patch from Patrick Strasser to fix grc prefs issue
authorBdale Garbee <bdale@gag.com>
Wed, 30 Dec 2009 03:11:59 +0000 (22:11 -0500)
committerBdale Garbee <bdale@gag.com>
Wed, 30 Dec 2009 03:11:59 +0000 (22:11 -0500)
debian/gen-install-files.sh
debian/prefs.py
debian/rules

index dfec38e16154854cda850f1239ecf19c8db5d81e..a6f364591d6abf0376355fdb4848189cf76e0909 100755 (executable)
@@ -335,7 +335,7 @@ echo usr/share/usrp/rev4/std_2rxint_2tx_dig.rbf >> $NAME
 NAME=debian/gnuradio-radar-mono.install
 rm -f $NAME
 touch $NAME
-$EXTRACT gr-radar-mono/src/python/Makefile radar_mono_python_PYTHON >>$NAME
+$EXTRACT gr-radar-mono/src/python/Makefile dist_ourpython_PYTHON >>$NAME
 $EXTRACT gr-radar-mono/src/python/Makefile dist_bin_SCRIPTS >>$NAME
 echo usr/share/usrp/rev2/usrp_radar_mono.rbf >>$NAME
 echo usr/share/usrp/rev4/usrp_radar_mono.rbf >>$NAME
index 452415b96a8c6e535ade2475354176bbe5976b0f..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,126 +0,0 @@
-#
-# Copyright 2006,2009 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
-
-import gnuradio_swig_python as gsp
-_prefs_base = gsp.gr_prefs
-
-
-import ConfigParser
-import os
-import os.path
-import sys
-
-
-def _user_prefs_filename():
-    return os.path.expanduser('~/.gnuradio/config.conf')
-        
-def _sys_prefs_dirname():
-    return '/etc/gnuradio/conf.d'
-
-def _bool(x):
-    """
-    Try to coerce obj to a True or False
-    """
-    if isinstance(x, bool):
-        return x
-    if isinstance(x, (float, int)):
-        return bool(x)
-    raise TypeError, x
-        
-
-class _prefs(_prefs_base):
-    """
-    Derive our 'real class' from the stubbed out base class that has support
-    for SWIG directors.  This allows C++ code to magically and transparently
-    invoke the methods in this python class.
-    """
-    def __init__(self):
-       _prefs_base.__init__(self)
-       self.cp = ConfigParser.RawConfigParser()
-       self.__getattr__ = lambda self, name: getattr(self.cp, name)
-
-    def _sys_prefs_filenames(self):
-        dir = _sys_prefs_dirname()
-        try:
-            fnames = os.listdir(dir)
-        except (IOError, OSError):
-            return []
-        fnames.sort()
-        return [os.path.join(dir, f) for f in fnames]
-
-    def _read_files(self):
-        filenames = self._sys_prefs_filenames()
-        filenames.append(_user_prefs_filename())
-        #print "filenames: ", filenames
-        self.cp.read(filenames)
-
-    # ----------------------------------------------------------------
-    # These methods override the C++ virtual methods of the same name
-    # ----------------------------------------------------------------
-    def has_section(self, section):
-        return self.cp.has_section(section)
-
-    def has_option(self, section, option):
-        return self.cp.has_option(section, option)
-
-    def get_string(self, section, option, default_val):
-        try:
-            return self.cp.get(section, option)
-        except:
-            return default_val
-
-    def get_bool(self, section, option, default_val):
-        try:
-            return self.cp.getboolean(section, option)
-        except:
-            return default_val
-
-    def get_long(self, section, option, default_val):
-        try:
-            return self.cp.getint(section, option)
-        except:
-            return default_val
-        
-    def get_double(self, section, option, default_val):
-        try:
-            return self.cp.getfloat(section, option)
-        except:
-            return default_val
-    # ----------------------------------------------------------------
-    #              End override of C++ virtual methods
-    # ----------------------------------------------------------------
-
-
-_prefs_db = _prefs()
-
-# if GR_DONT_LOAD_PREFS is set, don't load them.
-# (make check uses this to avoid interactions.)
-if os.getenv("GR_DONT_LOAD_PREFS", None) is None:
-    _prefs_db._read_files()
-    
-
-_prefs_base.set_singleton(_prefs_db)    # tell C++ what instance to use
-
-def prefs():
-    """
-    Return the global preference data base
-    """
-    return _prefs_db
index 3a4b1692ca0ddd75ea2dde5851df8ee1376edf98..4f33d26d876de197ddac30433038d83d193fb470 100755 (executable)
@@ -94,15 +94,10 @@ install-stamp: extract-stamp debian/control
        install -m 0644 -D debian/grc.conf \
                debian/tmp/etc/gnuradio/conf.d/grc.conf
 
-       : # Install custom prefs.py FIXME
-       install -m 0644 -D debian/prefs.py \
-               debian/tmp/usr/lib/python2.6/dist-packages/gnuradio/gr/prefs.py
-
        dh_install --sourcedir=debian/tmp
        touch $@
 
 
-
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep
 # in another 'make' thread.