Fix (actually a bit of a kludge) for the frequency setting while
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 27 Oct 2008 16:36:52 +0000 (16:36 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 27 Oct 2008 16:36:52 +0000 (16:36 +0000)
streaming problem.  You can now set the frequency in usrp2_fft.py
while streaming without dying :-)

git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@9878 221aa14e-8319-0410-a670-987f0aec2ac5

usrp2/firmware/apps/Makefile.am
usrp2/firmware/apps/app_common_v2.c
usrp2/firmware/apps/app_common_v2.h
usrp2/firmware/apps/factory_test.c
usrp2/firmware/apps/rx_only_v2.c [deleted file]
usrp2/firmware/apps/serdes_txrx.c
usrp2/firmware/apps/tx_only_v2.c [deleted file]
usrp2/firmware/apps/txrx.c

index b37c0f2914d72241957963d8eb1d72bab9e5bae5..0a14cf3c9126221ca4ed3fc9dcef814d77cefdcf 100644 (file)
@@ -31,7 +31,6 @@ noinst_PROGRAMS = \
        ibs_rx_test \
        ibs_tx_test \
        rcv_eth_packets \
-       rx_only_v2 \
        read_dbids \
        set_hw_rev \
        test1 \
@@ -44,7 +43,6 @@ noinst_PROGRAMS = \
        test_lsdac \
        test_serdes \
        timer_test \
-       tx_only_v2 \
        tx_standalone \
        txrx \
        factory_test \
@@ -56,8 +54,6 @@ noinst_PROGRAMS = \
 # tx_drop_SOURCES = tx_drop.c app_common.c
 # tx_drop_rate_limited_SOURCES = tx_drop_rate_limited.c app_common.c
 # tx_drop2_SOURCES = tx_drop2.c app_common.c
-rx_only_v2_SOURCES = rx_only_v2.c app_common_v2.c
-tx_only_v2_SOURCES = tx_only_v2.c app_common_v2.c
 txrx_SOURCES = txrx.c app_common_v2.c
 factory_test_SOURCES = factory_test.c app_common_v2.c
 eth_serdes_SOURCES = eth_serdes.c app_passthru_v2.c
index a8d7b92701b7c7980ffa10aa8dd2f14b8a15692e..d58ea8a41b7ca62ad6016e4471d0e8f66a5387a1 100644 (file)
@@ -40,7 +40,6 @@ dbsm_t *ac_could_be_sending_to_eth;
 
 static unsigned char exp_seqno __attribute__((unused)) = 0;
 
-
 static bool
 burn_mac_addr(const op_burn_mac_addr_t *p)
 {
@@ -145,10 +144,17 @@ config_tx_v2_cmd(const op_config_tx_v2_t *p,
   }
 
   if (p->valid & CFGV_FREQ){
+    bool was_streaming = is_streaming();
+    if (was_streaming)
+      stop_rx_cmd();
+    
     u2_fxpt_freq_t f = u2_fxpt_freq_from_hilo(p->freq_hi, p->freq_lo);
     bool tune_ok = db_tune(tx_dboard, f, &tune_result);
     ok &= tune_ok;
     print_tune_result("Tx", tune_ok, f, &tune_result);
+
+    if (was_streaming)
+      restart_streaming();
   }
 
   if (p->valid & CFGV_INTERP_DECIM){
@@ -212,10 +218,17 @@ config_rx_v2_cmd(const op_config_rx_v2_t *p,
   }
 
   if (p->valid & CFGV_FREQ){
+    bool was_streaming = is_streaming();
+    if (was_streaming)
+      stop_rx_cmd();
+    
     u2_fxpt_freq_t f = u2_fxpt_freq_from_hilo(p->freq_hi, p->freq_lo);
     bool tune_ok = db_tune(rx_dboard, f, &tune_result);
     ok &= tune_ok;
     print_tune_result("Rx", tune_ok, f, &tune_result);
+
+    if (was_streaming)
+      restart_streaming();
   }
 
   if (p->valid & CFGV_INTERP_DECIM){
index 30f54876c40e32b43f50017a387cf7be96bae06b..1a91ff0180b977a6823355e67468a35b9bcca677 100644 (file)
@@ -56,6 +56,8 @@ print_tune_result(char *msg, bool tune_ok,
 
 void start_rx_streaming_cmd(const u2_mac_addr_t *host, op_start_rx_streaming_t *p);
 void stop_rx_cmd(void);
+void restart_streaming(void);
+bool is_streaming(void);
 
 void handle_control_chan_frame(u2_eth_packet_t *pkt, size_t len);
 
index 4f7456cf4e2efda63100b8b8419cc5cff6e64546..b4b40b9f4f7b12668f924e220a971d45e0fd0688 100644 (file)
@@ -127,11 +127,12 @@ static unsigned int streaming_items_per_frame = 0;
 static int          streaming_frame_count = 0;
 #define FRAMES_PER_CMD 1000
 
+bool is_streaming(void){ return streaming_p; }
 
 // ----------------------------------------------------------------
 
 
-static void
+void
 restart_streaming(void)
 {
   // setup RX DSP regs
diff --git a/usrp2/firmware/apps/rx_only_v2.c b/usrp2/firmware/apps/rx_only_v2.c
deleted file mode 100644 (file)
index 303d340..0000000
+++ /dev/null
@@ -1,261 +0,0 @@
-/*
- * Copyright 2007 Free Software Foundation, Inc.
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-#ifdef HAVE_CONFIG_H
-#include "config.h"
-#endif
-
-#include "u2_init.h"
-#include "memory_map.h"
-#include "spi.h"
-#include "hal_io.h"
-#include "buffer_pool.h"
-#include "pic.h"
-#include "bool.h"
-#include "ethernet.h"
-#include "nonstdio.h"
-#include "usrp2_eth_packet.h"
-#include "memcpy_wa.h"
-#include "dbsm.h"
-#include "app_common_v2.h"
-#include <stddef.h>
-#include <stdlib.h>
-#include <string.h>
-#include <db.h>
-#include <db_base.h>
-
-
-#define FW_SETS_SEQNO  1       // define to 0 or 1
-
-#if (FW_SETS_SEQNO)
-static int fw_seqno;   // used when f/w is filling in sequence numbers
-#endif
-
-/*
- * This program can respond to queries from the host
- * and stream rx samples.
- *
- * Buffer 0 is used for rcvd frames from ethernet
- * Buffer 1 is used by the cpu to send frames to the host.
- * Buffers 2 and 3 are used to double-buffer the DSP Rx to eth flow
- */
-#define CPU_RX_BUF     0       // eth -> cpu
-//#define CPU_TX_BUF   1       // cpu -> eth
-#define        DSP_RX_BUF_0    2       // dsp rx -> eth (double buffer)
-#define        DSP_RX_BUF_1    3       // dsp rx -> eth
-
-
-// variables for streaming mode
-
-static bool     streaming_p = false;
-static int      streaming_frame_count = 0;
-#define FRAMES_PER_CMD 1000
-
-
-/*
- * ================================================================
- *      configure DSP RX double buffering state machine
- * ================================================================
- */
-
-// 4 lines of ethernet hdr + 1 line transport hdr + 1 line (word0)
-// DSP Rx writes timestamp followed by nlines_per_frame of samples
-#define DSP_RX_FIRST_LINE ((sizeof(u2_eth_hdr_t) + sizeof(u2_transport_hdr_t))/4 + 1)
-
-// receive from DSP
-buf_cmd_args_t dsp_rx_recv_args = {
-  PORT_DSP,
-  DSP_RX_FIRST_LINE,
-  BP_LAST_LINE
-};
-
-// send to ETH
-buf_cmd_args_t dsp_rx_send_args = {
-  PORT_ETH,
-  0,           // starts with ethernet header in line 0
-  0,           // filled in from list_line register
-};
-
-dbsm_t dsp_rx_sm;      // the state machine
-
-// ----------------------------------------------------------------
-
-
-
-// The mac address of the host we're sending to.
-u2_mac_addr_t host_mac_addr;
-
-
-void link_changed_callback(int speed);
-
-void
-start_rx_streaming_cmd(const u2_mac_addr_t *host, op_start_rx_streaming_t *p)
-{
-  host_mac_addr = *host;       // remember who we're sending to
-
-  /*
-   * Construct  ethernet header and word0 and preload into two buffers
-   */
-  u2_eth_packet_t      pkt;
-  memset(&pkt, 0, sizeof(pkt));
-  pkt.ehdr.dst = *host;
-  pkt.ehdr.ethertype = U2_ETHERTYPE;
-  u2p_set_word0(&pkt.fixed, 0, 0);
-  // DSP RX will fill in timestamp
-
-  memcpy_wa(buffer_ram(DSP_RX_BUF_0), &pkt, sizeof(pkt));
-  memcpy_wa(buffer_ram(DSP_RX_BUF_1), &pkt, sizeof(pkt));
-
-
-  if (FW_SETS_SEQNO)
-    fw_seqno = 0;
-
-  // setup RX DSP regs
-  dsp_rx_regs->clear_state = 1;                        // reset
-
-  if (1){                      // we're streaming
-    streaming_p = true;
-    streaming_frame_count = FRAMES_PER_CMD;
-    dsp_rx_regs->rx_command =
-      MK_RX_CMD(FRAMES_PER_CMD * p->items_per_frame, p->items_per_frame,
-               1, 1);                  // set "chain" bit
-
-    // kick off the state machine
-    dbsm_start(&dsp_rx_sm);
-    dsp_rx_regs->rx_time = 0;          // enqueue first of two commands
-
-    // make sure this one and the rest have the "now" and "chain" bits set.
-    dsp_rx_regs->rx_command =
-      MK_RX_CMD(FRAMES_PER_CMD * p->items_per_frame, p->items_per_frame,
-               1, 1);                          
-    dsp_rx_regs->rx_time = 0;                  // enqueue second command
-  }
-#if 0
-  else {
-    streaming_p = false;
-    dsp_rx_regs->rx_command =
-      MK_RX_CMD(p->total_samples, p->items_per_frame, p->rx_now, 0);
-
-    // kick off the state machine
-    dbsm_start(&dsp_rx_sm);
-    dsp_rx_regs->rx_time = p->rx_time;
-  }
-#endif
-}
-
-
-void
-stop_rx_cmd(void)
-{
-  streaming_p = false;
-  dsp_rx_regs->clear_state = 1;        // flush cmd queue
-  bp_clear_buf(DSP_RX_BUF_0);
-  bp_clear_buf(DSP_RX_BUF_1);
-}
-
-inline static void
-buffer_irq_handler(unsigned irq)
-{
-  uint32_t  status = buffer_pool_status->status;
-
-  if (status & BPS_DONE(CPU_RX_BUF)){  // we've rcvd a frame from ethernet
-    bp_clear_buf(CPU_RX_BUF);
-    eth_pkt_inspector(0, CPU_RX_BUF);
-    bp_receive_to_buf(CPU_RX_BUF, PORT_ETH, 1, 0, BP_LAST_LINE);
-  }
-  if (status & BPS_ERROR(CPU_RX_BUF)){ // error from ethernet
-    bp_clear_buf(CPU_RX_BUF);
-    bp_receive_to_buf(CPU_RX_BUF, PORT_ETH, 1, 0, BP_LAST_LINE);
-  }
-
-  dbsm_process_status(&dsp_rx_sm, status);
-
-  if (status & BPS_DONE(CPU_TX_BUF)){
-    bp_clear_buf(CPU_TX_BUF);
-  }
-}
-
-#if (FW_SETS_SEQNO)
-/*
- * Debugging ONLY.  This will be handled by the tx_protocol_engine.
- *
- * This is called when the DSP Rx chain has filled in a packet.
- * We set and increment the seqno, then return false, indicating
- * that we didn't handle the packet.  A bit of a kludge
- * but it should work.
- */
-bool 
-fw_sets_seqno_inspector(dbsm_t *sm, int buf_this)      // returns false
-{
-  uint32_t *p = buffer_ram(buf_this);
-  uint32_t seqno = fw_seqno++;
-
-  // KLUDGE all kinds of nasty magic numbers and embedded knowledge
-  uint32_t t = p[4];
-  t = (t & 0xffff00ff) | ((seqno & 0xff) << 8);
-  p[4] = t;
-
-  // queue up another rx command when required
-  if (streaming_p && --streaming_frame_count == 0){
-    streaming_frame_count = FRAMES_PER_CMD;
-    dsp_rx_regs->rx_time = 0;
-  }
-
-  return false;                // we didn't handle the packet
-}
-#endif
-
-
-int
-main(void)
-{
-  u2_init();
-
-  putstr("\nrx_only_v2\n");
-
-  ethernet_register_link_changed_callback(link_changed_callback);
-  ethernet_init();
-
-  // initialize double buffering state machine for DSP RX -> Ethernet
-
-  if (FW_SETS_SEQNO){
-    dbsm_init(&dsp_rx_sm, DSP_RX_BUF_0,
-             &dsp_rx_recv_args, &dsp_rx_send_args,
-             fw_sets_seqno_inspector);
-  }
-  else {
-    dbsm_init(&dsp_rx_sm, DSP_RX_BUF_0,
-             &dsp_rx_recv_args, &dsp_rx_send_args,
-             dbsm_nop_inspector);
-  }
-
-  // setup receive from ETH
-  bp_receive_to_buf(CPU_RX_BUF, PORT_ETH, 1, 0, BP_LAST_LINE);
-
-
-  while(1){
-    buffer_irq_handler(0);
-
-    int pending = pic_regs->pending;           // poll for under or overrun
-
-    if (pending & PIC_OVERRUN_INT){
-      dbsm_handle_rx_overrun(&dsp_rx_sm);
-      pic_regs->pending = PIC_OVERRUN_INT;     // clear pending interrupt
-      putchar('O');
-    }
-  }
-}
index 8f28a84f16599c06d6ff38c12611c97189423b70..3112829ab7cd73dc1dc2cb2026509b2dd96486f8 100644 (file)
@@ -124,11 +124,12 @@ static unsigned int streaming_items_per_frame = 0;
 static int          streaming_frame_count = 0;
 #define FRAMES_PER_CMD 1000
 
+bool is_streaming(void){ return streaming_p; }
 
 // ----------------------------------------------------------------
 
 
-static void
+void
 restart_streaming(void)
 {
   // setup RX DSP regs
diff --git a/usrp2/firmware/apps/tx_only_v2.c b/usrp2/firmware/apps/tx_only_v2.c
deleted file mode 100644 (file)
index f1e788d..0000000
+++ /dev/null
@@ -1,171 +0,0 @@
-/*
- * Copyright 2007,2008 Free Software Foundation, Inc.
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-#ifdef HAVE_CONFIG_H
-#include "config.h"
-#endif
-
-#include "u2_init.h"
-#include "memory_map.h"
-#include "spi.h"
-#include "hal_io.h"
-#include "buffer_pool.h"
-#include "pic.h"
-#include "bool.h"
-#include "ethernet.h"
-#include "nonstdio.h"
-#include "usrp2_eth_packet.h"
-#include "dbsm.h"
-#include "app_common_v2.h"
-#include <stddef.h>
-#include <stdlib.h>
-#include <string.h>
-#include <db.h>
-#include <db_base.h>
-
-
-/*
- * This program can respond to queries from the host
- * and stream rx samples.
- *
- * Buffer 1 is used by the cpu to send frames to the host.
- * Buffers 2 and 3 are used to double-buffer the DSP Rx to eth flow
- * Buffers 4 and 5 are used to double-buffer the eth to DSP Tx  eth flow
- */
-//#define CPU_RX_BUF   0       // eth -> cpu
-//#define CPU_TX_BUF   1       // cpu -> eth
-
-#define        DSP_RX_BUF_0    2       // dsp rx -> eth (double buffer)
-#define        DSP_RX_BUF_1    3       // dsp rx -> eth
-#define        DSP_TX_BUF_0    4       // eth -> dsp tx (double buffer)
-#define        DSP_TX_BUF_1    5       // eth -> dsp tx
-
-/*
- * ================================================================
- *      configure DSP TX double buffering state machine
- * ================================================================
- */
-
-// 4 lines of ethernet hdr + 1 line transport hdr + 2 lines (word0 + timestamp)
-// DSP Tx reads word0 (flags) + timestamp followed by samples
-
-#define DSP_TX_FIRST_LINE ((sizeof(u2_eth_hdr_t) + sizeof(u2_transport_hdr_t))/4)
-
-// Receive from ethernet
-buf_cmd_args_t dsp_tx_recv_args = {
-  PORT_ETH,
-  0,
-  BP_LAST_LINE
-};
-
-// send to DSP Tx
-buf_cmd_args_t dsp_tx_send_args = {
-  PORT_DSP,
-  DSP_TX_FIRST_LINE,   // starts just past transport header
-  0                    // filled in from last_line register
-};
-
-dbsm_t dsp_tx_sm;      // the state machine
-
-
-// ----------------------------------------------------------------
-
-
-// The mac address of the host we're sending to.
-u2_mac_addr_t host_mac_addr;
-
-
-void
-start_rx_streaming_cmd(const u2_mac_addr_t *host, op_start_rx_streaming_t *p)
-{
-  // FIXME nop
-}
-
-
-void
-stop_rx_cmd(void)
-{
-  // FIXME nop
-}
-
-
-static void
-setup_tx()
-{
-  dsp_tx_regs->clear_state = 1;
-  bp_clear_buf(DSP_TX_BUF_0);
-  bp_clear_buf(DSP_TX_BUF_1);
-
-  int tx_scale = 256;
-  int interp = 32;
-
-  // setup some defaults
-
-  dsp_tx_regs->freq = 0;
-  dsp_tx_regs->scale_iq = (tx_scale << 16) | tx_scale;
-  dsp_tx_regs->interp_rate = interp;
-}
-
-
-inline static void
-buffer_irq_handler(unsigned irq)
-{
-  //hal_toggle_leds(0x2);
-
-  uint32_t  status = buffer_pool_status->status;
-
-  dbsm_process_status(&dsp_tx_sm, status);
-
-  if (status & BPS_DONE(CPU_TX_BUF)){
-    bp_clear_buf(CPU_TX_BUF);
-  }
-}
-
-int
-main(void)
-{
-  u2_init();
-
-  putstr("\ntx_only_v2\n");
-
-  ethernet_register_link_changed_callback(link_changed_callback);
-  ethernet_init();
-
-  // initialize double buffering state machine for ethernet -> DSP Tx
-
-  dbsm_init(&dsp_tx_sm, DSP_TX_BUF_0,
-           &dsp_tx_recv_args, &dsp_tx_send_args,
-           eth_pkt_inspector);
-
-  // program tx registers
-  setup_tx();
-
-  // kick off the state machine
-  dbsm_start(&dsp_tx_sm);
-
-  while(1){
-    buffer_irq_handler(0);
-
-    int pending = pic_regs->pending;           // poll for under or overrun
-
-    if (pending & PIC_UNDERRUN_INT){
-      dbsm_handle_tx_underrun(&dsp_tx_sm);
-      pic_regs->pending = PIC_UNDERRUN_INT;    // clear interrupt
-      putchar('U');
-    }
-  }
-}
index e2c162113e97e266d72228d8bb3e7e7de5025aeb..730ee66c59fee791ebaf4c17fca805d6ff22347e 100644 (file)
@@ -123,11 +123,13 @@ static unsigned int streaming_items_per_frame = 0;
 static int          streaming_frame_count = 0;
 #define FRAMES_PER_CMD 1000
 
+bool is_streaming(void){ return streaming_p; }
+
 
 // ----------------------------------------------------------------
 
 
-static void
+void
 restart_streaming(void)
 {
   // setup RX DSP regs