Once and for all, here is the properly updated Makefile.am for the apps
[debian/gnuradio] / usrp2 / firmware / apps / Makefile.am
index 5931cf726cfdfd3c5d7d360bb7517c6e2157bc3a..2cbadd1ff79cbbe1de8ac194ad720b6c091041f7 100644 (file)
@@ -45,7 +45,13 @@ noinst_PROGRAMS = \
        timer_test \
        tx_standalone \
        txrx \
+       txrx_wbx \
+       txrx_xcvr \
+       txrx_bitshark_rx \
        factory_test \
+       burnrev30 \
+       burnrev31 \
+       burnrev40 \
        serdes_txrx \
        sd_gentest \
        sd_bounce \
@@ -58,12 +64,21 @@ noinst_PROGRAMS = \
 # tx_drop_rate_limited_SOURCES = tx_drop_rate_limited.c app_common.c
 # tx_drop2_SOURCES = tx_drop2.c app_common.c
 txrx_SOURCES = txrx.c app_common_v2.c
+txrx_wbx_SOURCES = txrx.c app_common_v2.c
+txrx_bitshark_rx_SOURCES = txrx.c app_common_v2.c
+txrx_xcvr_SOURCES = txrx.c app_common_v2.c
 factory_test_SOURCES = factory_test.c app_common_v2.c
 eth_serdes_SOURCES = eth_serdes.c app_passthru_v2.c
 serdes_txrx_SOURCES = serdes_txrx.c app_common_v2.c
 mimo_tx_SOURCES = mimo_tx.c mimo_app_common_v2.c
 mimo_tx_slave_SOURCES = mimo_tx_slave.c app_common_v2.c
 
+txrx_wbx_LDADD = ../lib/libu2fw_wbx.a
+
+txrx_xcvr_LDADD = ../lib/libu2fw_xcvr.a
+
+txrx_bitshark_rx_LDADD = ../lib/libu2fw_burx.a
+
 noinst_HEADERS = \
         app_common_v2.h \
         app_passthru_v2.h \