Once and for all, here is the properly updated Makefile.am for the apps
[debian/gnuradio] / usrp2 / firmware / apps / Makefile.am
index 045a05ab4513f3c961adffa192ce50f78cc23b17..2cbadd1ff79cbbe1de8ac194ad720b6c091041f7 100644 (file)
@@ -46,6 +46,8 @@ noinst_PROGRAMS = \
        tx_standalone \
        txrx \
        txrx_wbx \
+       txrx_xcvr \
+       txrx_bitshark_rx \
        factory_test \
        burnrev30 \
        burnrev31 \
@@ -63,6 +65,8 @@ noinst_PROGRAMS = \
 # tx_drop2_SOURCES = tx_drop2.c app_common.c
 txrx_SOURCES = txrx.c app_common_v2.c
 txrx_wbx_SOURCES = txrx.c app_common_v2.c
+txrx_bitshark_rx_SOURCES = txrx.c app_common_v2.c
+txrx_xcvr_SOURCES = txrx.c app_common_v2.c
 factory_test_SOURCES = factory_test.c app_common_v2.c
 eth_serdes_SOURCES = eth_serdes.c app_passthru_v2.c
 serdes_txrx_SOURCES = serdes_txrx.c app_common_v2.c
@@ -71,6 +75,10 @@ mimo_tx_slave_SOURCES = mimo_tx_slave.c app_common_v2.c
 
 txrx_wbx_LDADD = ../lib/libu2fw_wbx.a
 
+txrx_xcvr_LDADD = ../lib/libu2fw_xcvr.a
+
+txrx_bitshark_rx_LDADD = ../lib/libu2fw_burx.a
+
 noinst_HEADERS = \
         app_common_v2.h \
         app_passthru_v2.h \