grc: rename execution binary from 'grc' to 'gnuradio-companion'
[debian/gnuradio] / Makefile.am
index 89ad013c8ab966ec000d9c15f5e21b29eb166e82..084fb5dc16312c88c7efa134495fbe787b562676 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2001,2006,2008 Free Software Foundation, Inc.
+# Copyright 2001,2006,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -24,10 +24,30 @@ ACLOCAL_AMFLAGS = -I config
 include $(top_srcdir)/Makefile.common
 
 EXTRA_DIST = \
+       bootstrap \
        configure \
+       configure-cell-cross \
        config.h.in \
        run_tests.sh.in \
-       README.hacking
+       Makefile.swig \
+       Makefile.swig.gen.t \
+       Makefile.par.gen \
+       Makefile.gen.gen \
+       version.sh
 
 SUBDIRS = @build_dirs@
 DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@
+DISTCLEANFILES = gnuradio*.tar.gz
+
+if PYTHON
+
+export pythondir
+
+install-data-hook:
+       @if ! python -c "import gnuradio" > /dev/null 2>&1; then\
+               printf "\n*** Post-Install Message ***\
+               \nWarning: python could not find the gnuradio module.\
+               \nMake sure that $${pythondir} is in your PYTHONPATH\n\n";\
+       fi
+
+endif