gnuradio-core: Disable (temporarily) interpolator tap calculation
[debian/gnuradio] / Makefile.am
index 0d6e01b056f4ae6684378c94e0d10a3da7fb9054..084fb5dc16312c88c7efa134495fbe787b562676 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2001,2006 Free Software Foundation, Inc.
+# Copyright 2001,2006,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -26,9 +26,28 @@ include $(top_srcdir)/Makefile.common
 EXTRA_DIST = \
        bootstrap \
        configure \
+       configure-cell-cross \
        config.h.in \
        run_tests.sh.in \
-       README.hacking
+       Makefile.swig \
+       Makefile.swig.gen.t \
+       Makefile.par.gen \
+       Makefile.gen.gen \
+       version.sh
 
 SUBDIRS = @build_dirs@
-DIST_SUBDIRS = @build_dirs@ @skipped_dirs@
+DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@
+DISTCLEANFILES = gnuradio*.tar.gz
+
+if PYTHON
+
+export pythondir
+
+install-data-hook:
+       @if ! python -c "import gnuradio" > /dev/null 2>&1; then\
+               printf "\n*** Post-Install Message ***\
+               \nWarning: python could not find the gnuradio module.\
+               \nMake sure that $${pythondir} is in your PYTHONPATH\n\n";\
+       fi
+
+endif