Imported Debian patch 5.1-10 debian/5.1-10
authorBdale Garbee <bdale@gag.com>
Sat, 28 Apr 2007 17:01:23 +0000 (11:01 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 05:11:11 +0000 (23:11 -0600)
debian/changelog
debian/control
debian/gcpegg.1
debian/init.d
debian/rules
reg_orion.c
reg_pear.c
regtest.c

index 49c829b547cb6d9445d38d208f7504e666b392f3..fb5161d8a641baa6e4e02e7f64d14449f14ea87b 100644 (file)
@@ -1,3 +1,13 @@
+gcpegg (5.1-10) unstable; urgency=low
+
+  * add a purge target to the init.d script, closes: #367123
+  * merge patch that adds support for Debian/kfreebsd, closes: #414405
+  * rename 'basket' to 'gcpbasket' to avoid package conflict, closes: #420632
+  * add LSB structure to init.d
+  * update standards version
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 28 Apr 2007 11:01:23 -0600
+
 gcpegg (5.1-9) unstable; urgency=low
 
   * use fully qualified pathnames in init.d, addresses another part of 347778
 gcpegg (5.1-9) unstable; urgency=low
 
   * use fully qualified pathnames in init.d, addresses another part of 347778
index 052a0d40009a121ed568f1aece1f84413201e3c5..0553a25d9329a2998941c913d0a6227876c1f30d 100644 (file)
@@ -3,7 +3,7 @@ Section: misc
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Depends: debhelper (>= 5), libncurses-dev
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Depends: debhelper (>= 5), libncurses-dev
-Standards-Version: 3.6.2.1
+Standards-Version: 3.7.2
 
 Package: gcpegg
 Architecture: any
 
 Package: gcpegg
 Architecture: any
index afbcbc39d0bfa1fd4d8137d8eea11c84752c08ab..78a440a267b9a79b7a0b5f24e8cfc310522e161f 100644 (file)
@@ -2,7 +2,7 @@
 .SH NAME
 gcpegg \- Global Consciousness Project REG Software
 .SH SYNOPSIS
 .SH NAME
 gcpegg \- Global Consciousness Project REG Software
 .SH SYNOPSIS
-.B basket
+.B gcpbasket
 .br
 .B eggsh
 .br
 .br
 .B eggsh
 .br
@@ -23,7 +23,7 @@ launched at boot and runs persistently.  Is is configured using the
 /etc/eggrc file.
 
 The
 /etc/eggrc file.
 
 The
-.B basket
+.B gcpbasket
 command is the data collector, and is not normally needed by an EGG
 site.
 
 command is the data collector, and is not normally needed by an EGG
 site.
 
index 399271989caa91e179964f6d07aada2c9dce37c9..6f0e2c9c2b28043a67bdde9a83e3d92b78b07362 100644 (file)
@@ -1,5 +1,14 @@
 #!/bin/sh
 
 #!/bin/sh
 
+### BEGIN INIT INFO
+# Provides:          gcpegg
+# Required-Start:    $local_fs
+# Required-Stop:
+# Default-Start:     2 3 4 5
+# Default-Stop:      0 1 6
+# Short-Description: Start GCP EGG software on virtual terminal 8
+### END INIT INFO
+
 set -e
 
 test -x /usr/sbin/eggsh || exit 0
 set -e
 
 test -x /usr/sbin/eggsh || exit 0
@@ -24,8 +33,13 @@ case "$1" in
        /usr/bin/openvt -f -c 8 /usr/sbin/eggsh
        echo "done."
        ;;
        /usr/bin/openvt -f -c 8 /usr/sbin/eggsh
        echo "done."
        ;;
+  purge)
+       echo -n "Purging all previously generated data by GCP EGG"  
+       rm -r /var/spool/gcpegg/*
+       echo "done."    
+       ;;
   *)
   *)
-        echo "Usage: /etc/init.d/gcpegg {start|stop|reload|force-reload|restart}"
+        echo "Usage: /etc/init.d/gcpegg {start|stop|reload|force-reload|restart|purge}"
         exit 1
        ;;
 esac
         exit 1
        ;;
 esac
index a9f7ee6b44258726152e420e43dec83103c00861..6e16a2ffdcba635947839e612b304d43f28e2246 100755 (executable)
@@ -23,14 +23,15 @@ install-stamp: build-stamp
        dh_installdirs
        /usr/bin/install -o root -g root -m 0755 eggsh debian/gcpegg/usr/sbin
        /usr/bin/install -o root -g root -m 0755 regtest debian/gcpegg/usr/sbin
        dh_installdirs
        /usr/bin/install -o root -g root -m 0755 eggsh debian/gcpegg/usr/sbin
        /usr/bin/install -o root -g root -m 0755 regtest debian/gcpegg/usr/sbin
-       /usr/bin/install -o root -g root -m 0755 basket debian/gcpegg/usr/sbin
+       /usr/bin/install -o root -g root -m 0755 basket \
+               debian/gcpegg/usr/sbin/gcpbasket
        /usr/bin/install -o root -g root -m 0644 eggrc.sample \
                debian/gcpegg/etc/eggrc
        /usr/bin/install -o root -g root -m 0644 debian/gcpegg.1 \
                debian/gcpegg/usr/share/man/man1/gcpegg.1
        gzip -9 debian/gcpegg/usr/share/man/man1/gcpegg.1
        ( cd debian/gcpegg/usr/share/man/man1 ; \
        /usr/bin/install -o root -g root -m 0644 eggrc.sample \
                debian/gcpegg/etc/eggrc
        /usr/bin/install -o root -g root -m 0644 debian/gcpegg.1 \
                debian/gcpegg/usr/share/man/man1/gcpegg.1
        gzip -9 debian/gcpegg/usr/share/man/man1/gcpegg.1
        ( cd debian/gcpegg/usr/share/man/man1 ; \
-                ln gcpegg.1.gz basket.1.gz ;\
+                ln gcpegg.1.gz gcpbasket.1.gz ;\
                 ln gcpegg.1.gz eggsh.1.gz ;\
                 ln gcpegg.1.gz regtest.1.gz )
        touch install-stamp
                 ln gcpegg.1.gz eggsh.1.gz ;\
                 ln gcpegg.1.gz regtest.1.gz )
        touch install-stamp
index d6938ef30dca1810040a0c00f65a9293d8141cfc..ccb1189562b18b1f3d213bc33c45be86d2c1a991 100644 (file)
@@ -147,7 +147,9 @@ fprintf(stderr, "Error in open(%s)\n", ttydev);
 #else
   res = cfsetospeed(&tt, baudcon); 
   cfmakeraw(&tt);
 #else
   res = cfsetospeed(&tt, baudcon); 
   cfmakeraw(&tt);
+#if !defined(__FreeBSD_kernel__)
   tt.c_oflag &= (~(TABDLY | ONLCR));
   tt.c_oflag &= (~(TABDLY | ONLCR));
+#endif
 #endif
   res = tcsetattr(TTY_fd, TCSANOW, &tt);
 
 #endif
   res = tcsetattr(TTY_fd, TCSANOW, &tt);
 
index bc79bb702920bd432bfb6ba07a5a38ccf613505d..87755378b88f195e698d6e2e2655c666faf96f8d 100644 (file)
@@ -122,7 +122,9 @@ static int32 OpenDev(DevOpts *opts) {
 #else
   res = cfsetospeed(&tt, baudcon); 
   cfmakeraw(&tt);
 #else
   res = cfsetospeed(&tt, baudcon); 
   cfmakeraw(&tt);
+#if !defined(__FreeBSD_kernel__)
   tt.c_oflag &= (~(TABDLY | ONLCR));
   tt.c_oflag &= (~(TABDLY | ONLCR));
+#endif
 #endif
   res = tcsetattr(TTY_fd, TCSANOW, &tt);
 
 #endif
   res = tcsetattr(TTY_fd, TCSANOW, &tt);
 
index 5d3f6c8b40dcf5d667e544561f93a72bdc162de5..397dd60e128b8716f98f41409e6ee84008fae5c8 100644 (file)
--- a/regtest.c
+++ b/regtest.c
 #define __USE_BSD
 #include <errno.h>
 #undef __USE_BSD
 #define __USE_BSD
 #include <errno.h>
 #undef __USE_BSD
+#if defined(__FreeBSD_kernel__)
+/* Not patching the code directly, used once, in a "|" context */
+#define O_NDELAY 0
+#endif
 
 #include <sys/types.h>
 #include <sys/stat.h>
 
 #include <sys/types.h>
 #include <sys/stat.h>
@@ -56,7 +60,9 @@ int main(int argc, char *argv[]) {
   res = tcgetattr(TTY_fd, &tt);
   res = cfsetospeed(&tt, baud); 
   cfmakeraw(&tt);
   res = tcgetattr(TTY_fd, &tt);
   res = cfsetospeed(&tt, baud); 
   cfmakeraw(&tt);
+#if !defined(__FreeBSD_kernel__)
   tt.c_oflag &= (~(TABDLY | ONLCR));
   tt.c_oflag &= (~(TABDLY | ONLCR));
+#endif
   res = tcsetattr(TTY_fd, TCSANOW, &tt);
 
   mean = 0;
   res = tcsetattr(TTY_fd, TCSANOW, &tt);
 
   mean = 0;