modify eggsh to always open /dev/REG which can be symlinked to the actual
authorBdale Garbee <bdale@thor.gag.com>
Tue, 3 Jul 2012 21:04:38 +0000 (15:04 -0600)
committerBdale Garbee <bdale@thor.gag.com>
Tue, 3 Jul 2012 21:04:38 +0000 (15:04 -0600)
device, so that we can use USB serial ports, etc

debian/README.debian
debian/changelog
hw_pear.c
reg_orion.c
reg_pear.c
sample.eggrc

index 1dd777c95f6301a16865a44708b962366ea788bf..ee8d99df9ea50025a3fbb1986ac6d2e35e735021 100644 (file)
@@ -1,3 +1,16 @@
+The upstream source assumes you will use a traditional hard-wired serial
+port, but those are getting rare.  Rather than refactor the code, I've just
+made the Debian package always open the device /dev/REG.  All you need to
+do is symlink this to whatever your actual serial port is with something like:
+
+       cd /dev
+       ln -s ttyUSB0 REG
+
+The 'port' field in the REG line of the eggrc file will be ignored, so just
+leave it set to '0'.
+
+                       - - - - -
+
 If the EGG computer is behind a firewall, it must be programmed
 to allow UDP packets on port 2510 outgoing packet and UDP port
 1105 for an incoming connection.
@@ -8,10 +21,3 @@ to be transmitted. What happens is that your program sends an
 responds with a "data request" packet, and then the EGG program
 will send the data.
 
-                       - - - - -
-
-This package is known to compile but not run successfully on at 
-least the amd64 architecture.  The only architecture it has really
-been tested on is i386...  If anyone is sufficiently motivated
-to chase down and fix whatever the problem is, patches would be 
-welcomed!
index 0d8dabe434b333e6e6bbda583988e06ca82d24c9..d074e77089d72c294247a4a0f2b2f0b5581f4705 100644 (file)
@@ -2,8 +2,11 @@ gcpegg (5.1-12.64) UNRELEASED; urgency=low
 
   * merge 64-bit fixes from Fernando Lucas Rodriguez <fernando_lr@terra.es>,
     closes: #680014
+  * fix additional 64-bit isms in the UI code
   * revise dependency to be kbd | console-tools to ease backport support
   * unqualify openvt path in init.d to tolerate /bin vs /usr/bin
+  * enable the use of USB serial ports, etc, by making eggsh always open 
+    /dev/REG, which is now assumed to be a symlink to the actual device
 
  -- Bdale Garbee <bdale@gag.com>  Mon, 02 Jul 2012 14:59:55 -0600
 
index 401d307356c9f19d9940e4e08be5d644fe454e6c..f7d4e9957554a2fd412fdc768ec45fd62db66f72 100644 (file)
--- a/hw_pear.c
+++ b/hw_pear.c
@@ -87,7 +87,7 @@ int32 OpenDev(DevOpts *opts) {
      designating /dev/term/a. */
   sprintf(ttydev, "/dev/term/%c", 'a' + (opts->port - 1));
 #else
-  sprintf(ttydev, "/dev/ttyS%d", opts->port);
+  sprintf(ttydev, "/dev/REG", opts->port);
 #endif
 
   switch(opts->baud) {
index c88ac38d0eb2cfa9a5167b4b4c04bbea75b4d324..b3985b850a5f8b36814ca1cdd211df7e08566e70 100644 (file)
@@ -97,7 +97,7 @@ static int32 OpenDev(DevOpts *opts) {
   sprintf(ttydev, "/dev/term/%c", 'a' + (opts->port - 1));
 #endif
 #else
-  sprintf(ttydev, "/dev/ttyS%d", opts->port);
+  sprintf(ttydev, "/dev/REG", opts->port);
 #endif
 
   switch(opts->baud) {
index 7bb7c5ca25a658ccbdbbf1aa82fe2d93094f44a2..0ff329959eb4735ff53c52f09a403bd1adda84f9 100644 (file)
@@ -77,7 +77,7 @@ static int32 OpenDev(DevOpts *opts) {
   sprintf(ttydev, "/dev/term/%c", 'a' + (opts->port - 1));
 #endif
 #else
-  sprintf(ttydev, "/dev/ttyS%d", opts->port);
+  sprintf(ttydev, "/dev/REG", opts->port);
 #endif
 
   switch(opts->baud) {
index 3fd961dc73ccbc90f49d79fee03482d285c4775a..4ce300cacc35942526805b3184a516b161a52fb7 100644 (file)
@@ -38,6 +38,9 @@
 # this time.  Port is serial port number (e.g. 1 for /dev/ttyS1);
 # <baud> is baud rate.
 #
+#      NOTE: in Debian, the device opened is always /dev/REG!
+#            Symlink that to whatever your actual serial device is.
+#
 #   NETUP <script> <args> ...
 #   NETDOWN <script> <args> ...
 #