working on lintian complaints
authorBdale Garbee <bdale@gag.com>
Thu, 10 Nov 2011 22:09:43 +0000 (15:09 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 10 Nov 2011 22:09:43 +0000 (15:09 -0700)
debian/control
debian/init.d
debian/rules

index 96ba6dcc75dacae7205e598262acdcc389d7cd38..d6b276ebf8dad5a58429d7484c38b2a31cc67751 100644 (file)
@@ -9,7 +9,7 @@ Vcs-Browser: http://git.gag.com/?p=debian/gcpegg
 
 Package: gcpegg
 Architecture: linux-any
-Depends: ${shlibs:Depends}, console-tools
+Depends: ${shlibs:Depends}, ${misc:Depends}, console-tools
 Description: Global Consciousness Project EGG Software
  The GCP studies data from random event generators in widely distributed
  locations, to discern non-random patterns that may result from the
index 6f0e2c9c2b28043a67bdde9a83e3d92b78b07362..b04ffb0cc6998ac6ba8680e822a8305499b1b43b 100644 (file)
@@ -2,8 +2,8 @@
 
 ### BEGIN INIT INFO
 # Provides:          gcpegg
-# Required-Start:    $local_fs
-# Required-Stop:
+# Required-Start:    $local_fs $remote_fs
+# Required-Stop:     $local_fs $remote_fs
 # Default-Start:     2 3 4 5
 # Default-Stop:      0 1 6
 # Short-Description: Start GCP EGG software on virtual terminal 8
index 6e16a2ffdcba635947839e612b304d43f28e2246..2adef4ce9b25c4bb642dd8c5d40828276be7fcf9 100755 (executable)
@@ -2,7 +2,9 @@
 
 export DH_VERBOSE=1
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 build-stamp:
        dh_testdir
        $(MAKE) 
@@ -12,7 +14,7 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp install-stamp
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
        dh_clean
 
 install: install-stamp
@@ -63,4 +65,4 @@ source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build build-arch build-indep clean binary binary-arch binary-indep