add ant stuff
authorBdale Garbee <bdale@gag.com>
Tue, 18 May 2010 19:24:30 +0000 (13:24 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 18 May 2010 19:24:30 +0000 (13:24 -0600)
debian/control
debian/rules

index f3a2c9c8ec1e645c2f808ba5653eb20633e6504c..793cfb18a4fe3c58d3465db4b7f93e32e421f9f9 100644 (file)
@@ -1,7 +1,7 @@
 Source: freetts
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 7), default-jdk
+Build-Depends: debhelper (>= 7), default-jdk, ant, ant-optional, junit4
 Standards-Version: 3.8.4
 Section: java
 Vcs-Git: git://git.gag.com/debian/freetts
@@ -11,7 +11,7 @@ Homepage: http://freetts.sourceforge.net
 Package: freetts
 Section: java
 Architecture: all
-Depends: default-jre | java2-runtime, ${misc:Depends}
+Depends: default-jre | java2-runtime, ${shlibs:Depends}, ${misc:Depends}
 Description: speech synthesis system
  FreeTTS is a speech synthesis system written entirely in the Java(TM) 
  programming language.  It is based upon Flite, a small run-time speech 
index 917d9bf25deb90bc3cd843717dc94359fcc02eb6..12e9e6bde0a3333269a52ca0546924a57ed447a3 100755 (executable)
 
 %:
        dh  $@
+
+override_dh_auto_build:
+       ant deploy_bin
+
+#override_dh_auto_install:
+#      cp build/jar/* `pwd`/debian/openrocket/usr/share/java/
+#      printf '#!/bin/sh\njava -jar /usr/share/java/%s\n' \
+#              "`/bin/ls build/jar`" > \
+#              `pwd`/debian/openrocket/usr/bin/openrocket
+
+#override_dh_installman:
+#      dh_installman debian/openrocket.1
+